logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Build Tests ;)

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
Lutz-R. Frank



Joined: 03 Dec 2005
Posts: 21
Location: Germany

PostPosted: Wed 07 Dec '05 20:19    Post subject: Build Tests ;) Reply with quote

Code:

 link.exe @...\Temp\nm1816.tmp
   Creating library .\Release\mod_ssl.lib and object .\Release\mod_ssl.exp
ssl_expr.obj : error LNK2019: unresolved external symbol _ssl_expr_yyparse referenced in function _ssl_expr_comp
.\Release\mod_ssl.so : fatal error LNK1120: 1 unresolved externals
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\bin\link.exe"' : return code '0x460'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\bin\nmake.exe"' : return code '0x2'
Stop.
Project : error PRJ0019: A tool returned an error code from "Performing Makefile project actions"


what a I doing wrong??

And - is there a trick to build zLib 1.2.3???

Thanks

Lutz
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Thu 08 Dec '05 0:19    Post subject: Reply with quote

Looks like it does not find the openssl libs. You must first build openssl, there I had to add;

In openssl (srclib\openssl\util\pl\VC-32.pl) I added the flags:

-D_CRT_NONSTDC_NO_DEPRECATE
-D_USE_32BIT_TIME_T

And then build manual openssl as described in the readme file.


To build zlib1.1.3 , use the .dsw from the /projects/visualc6 directory for a IDE build.

Steffen
Back to top
Lutz-R. Frank



Joined: 03 Dec 2005
Posts: 21
Location: Germany

PostPosted: Thu 08 Dec '05 9:02    Post subject: Reply with quote

Thanks Steffen - at least I've got zlib now compiled and my .lib file Smile
(my 1.1.4 zip didn't contain a projects folder)


Somehow my Visual Studio behaves strange - I got it once to build mod_ssl ... and since then the errors - I played around with debug and release builds.
The openssl sources are built perfectly and sitting in my srclib/openssl/outdll32 folder. How can I point my project to look there or do I have to copy the lib/dll to another place within my project?

Thats how I tried it now
- select buildbin as Startup Project
- adjusted its properties to Release(Active) and the output path
- deselected mod_deflate and mod_ssl
- build buildbin

- build openssl as described
...\openssl> perl Configure VC-NT
...\openssl> ms\do_masm.bat
...\openssl> perl util\mk1mf.pl debug dll VC-NT 1>ms\ntdlldebug.mak
- changed the mak's as you porposed (added flags) and remove /WX
...\openssl> copy ms\libeay32.def ms\libeay32d.def
...\openssl> copy ms\ssleay32.def ms\ssleay32d.def
...\openssl> perl util\mk1mf.pl dll VC-NT 1>ms\ntdll.mak

- build buildbin again
here I got the errors (until last night - will try after work Wink)

The new Studio2005 makes a few things slightly different (as it looks) - I'm not familiar with all its options - sigh ...


Last edited by Lutz-R. Frank on Thu 08 Dec '05 11:23; edited 1 time in total
Back to top
Lutz-R. Frank



Joined: 03 Dec 2005
Posts: 21
Location: Germany

PostPosted: Thu 08 Dec '05 11:16    Post subject: Reply with quote

that's my error - and zlib.lib is available in
srclib\zlib\lib
Code:

 zdll.exp                         6109 bytes  Mon 18/Jul/2005 18:25 file
 zdll.lib                           10 kbytes Mon 18/Jul/2005 18:25 file
 zlib.def                          981 bytes  Sat 08/Nov/2003 00:00 file



Code:
mod_deflate.c(869) : warning C4996: 'stricmp' was declared deprecated
        C:\Program Files\Microsoft Visual Studio 8\VC\include\string.h(213) : see declaration of 'stricmp'
        Message: 'The POSIX name for this item is deprecated. Instead, use the ISO C++ conformant name: _stricmp. See online help for details.'
 link.exe @C:\DOCUME~1\LUTZ-R~1.FRA\LOCALS~1\Temp\nm1F3F.tmp
LINK : fatal error LNK1181: cannot open input file 'zlib.lib'
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\bin\link.exe"' : return code '0x49d'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\bin\nmake.exe"' : return code '0x2'
Stop.
Project : error PRJ0019: A tool returned an error code from "Performing Makefile project actions"


Sad could this >
Code:

CPP_PROJ=/nologo /MD /W3 /Zi /O2 /Oy- /I "../../include" /I "../../srclib/apr/include" /I "../../srclib/apr-util/include" /I "../../srclib/zlib" /D "NDEBUG" /D "WIN32" /D "_WINDOWS" /Fo"$(INTDIR)\\" /Fd"$(INTDIR)\mod_deflate_src" /FD /c

be the reason? the mod_deflate.mak only points to "../srclib/zlib" not "../srclib/zlib/lib" ??

and the mod_ssl.mak
Code:

CPP_PROJ=/nologo /MD /W3 /Zi /O2 /Oy- /I "../../include" /I "../generators" /I "../../srclib/apr/include" /I "../../srclib/apr-util/include" /I "../../srclib/openssl/inc32"

and no out32dll - the inc32 only contains a openssl folder with .h files

??
Back to top
Lutz-R. Frank



Joined: 03 Dec 2005
Posts: 21
Location: Germany

PostPosted: Fri 09 Dec '05 9:52    Post subject: Help please !! Reply with quote

no idea yet?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Fri 09 Dec '05 12:54    Post subject: Reply with quote

Copy zlib.lib to \srclib\zlib

When you have no out32dll folder, then it looks you did not build ssl
Back to top
Lutz-R. Frank



Joined: 03 Dec 2005
Posts: 21
Location: Germany

PostPosted: Fri 09 Dec '05 13:08    Post subject: Reply with quote

No .. I've got the out32dll folder with all apps and the tests are running with no issues - I meant the include in the mod_sll.mak does not point to the out32dll folder.
Back to top
Lutz-R. Frank



Joined: 03 Dec 2005
Posts: 21
Location: Germany

PostPosted: Fri 09 Dec '05 22:55    Post subject: Reply with quote

Got now mod_deflate built after putting zlib.lib into the zlib DIR directly.
Still no success getting mod_ssl built

Code:
------ Build started: Project: mod_ssl, Configuration: Release Win32 ------
Compiling...
ssl_expr_parse.c
y.tab.c(926) : error C2449: found '{' at file scope (missing function header?)
y.tab.c(1598) : error C2059: syntax error : '}'
Build log was saved at "file://c:\Documents and Settings\Lutz-R. Frank\My Documents\Visual Studio 2005\Projects\Webserver\modules\ssl\Release\BuildLog.htm"
mod_ssl - 2 error(s), 0 warning(s)


and at the end ...

Code:
------ Build started: Project: mod_ssl, Configuration: Release Win32 ------
Compiling...
ssl_expr_parse.c
y.tab.c(926) : error C2449: found '{' at file scope (missing function header?)
y.tab.c(1598) : error C2059: syntax error : '}'
Build log was saved at "file://c:\Documents and Settings\Lutz-R. Frank\My Documents\Visual Studio 2005\Projects\Webserver\modules\ssl\Release\BuildLog.htm"
mod_ssl - 2 error(s), 0 warning(s)


Any helpfull idea??
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1