logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.



[warn] Init: Session Cache is not configured [hint: SSLSessi

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
dannygouchi



Joined: 14 Feb 2010
Posts: 3
Location: London

PostPosted: Mon 15 Feb '10 5:04    Post subject: [warn] Init: Session Cache is not configured [hint: SSLSessi Reply with quote

Hey guys, im kinda new to all this but sure am i good learner.

I have installed Apache 2.2.14 / Php 5.2.12 / Mysql 5.1.43-community Server (GPL) running them all from the same machine using windows xp home sp3.

Ive been trying to install PhpMyAdmin and configure it, but everytime i run the loggin page, Apache generates an error ...

Apache HTTP Server has encountered a problem and needs to close. We are sorry for the inconvenience.
.........................................................................................................

Tho it seems not too be the case,
Apache is still running and other php pages run ok from the server without me restarting it !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

So what do we do first? ..... yep look in the error log files .........
I have 1 error their saying ...

[warn] Init: Session Cache is not configured [hint: SSLSessionCache]

Could this error be the cause of PhpMyAdmin making Apache generate that error when i try to loggon, i dont no.
But PhpMyAdmin is the first app im installing that use's MySql and Apache, all my other pages are just php without database requirements.
.........................................................................................................

After comming across this article http://wiki.apache.org/httpd/SSLSessionCache

I followed hes configuration but Apache wont start up when i enable the httpd-ssl conf file in the httpd file, when i disable it Apache starts up again.
I must be missing something out thats not explained on that page.

Ive tried to get as much info onto this forum page for help.

All i want is to have Apache php mysql with phpmyadmin working.

...........................................................................................................
THIS IS MY MySql Server status

C:\Program Files\MySQL\MySQL Server 5.1\bin\mysql.exe Ver 14.14 Distrib 5.1.43,
for Win32 (ia32)

Connection id: 6
Current database:
Current user: root@localhost
SSL: Not in use
Using delimiter: ;
Server version: 5.1.43-community MySQL Community Server (GPL)
Protocol version: 10
Connection: localhost via TCP/IP
Server characterset: latin1
Db characterset: latin1
Client characterset: latin1
Conn. characterset: latin1
TCP port: 3306
Uptime: 6 hours 27 min 23 sec

Threads: 1 Questions: 21 Slow queries: 0 Opens: 15 Flush tables: 1 Open tab
les: 0 Queries per second avg: 0.0
...........................................................................................................
php.ini
http://pastebin.de/3979
...........................................................................................................
http conf file

http://pastebin.de/3980

Mod Note: Moved config files to pastebin. Do not post your whole config files to the forum. We know the standart settings. If you have to, post only relevant things.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 1956

PostPosted: Mon 15 Feb '10 13:04    Post subject: Reply with quote

Since you are obviously NOT using SSL ... comment out the loadmodule line for mod_ssl

#LoadModule ssl_module modules/mod_ssl.so
Back to top
dannygouchi



Joined: 14 Feb 2010
Posts: 3
Location: London

PostPosted: Mon 15 Feb '10 17:24    Post subject: Reply with quote

Hi glsmith ... tnx for your reply, ive commented out the #LoadModule ssl_module modules_ssl.so / i still get the same error with Apache =

Apache HTTP Server has encountered a problem and needs to close. We are sorry for the inconvenience.

If i use the = LoadModule ssl_module modules_ssl.so / is gives me the same error when i try to loggin to PhpMyAdmin.
Back to top
dannygouchi



Joined: 14 Feb 2010
Posts: 3
Location: London

PostPosted: Mon 15 Feb '10 17:25    Post subject: Reply with quote

Im also restarting the server everytime i make a change to the httpd file.

Please guys i neeed help here .....
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 1956

PostPosted: Mon 15 Feb '10 22:13    Post subject: Reply with quote

Well .. I see nothing in your config other than your loading SSL with no config ... but your config, at least the one that got moved to pastebin is incomplete, it is missing all the Include lines near the bottom.

However, not loading mod_ssl should not keep the server from running.

So I'd look at phpmyadmin ... seems when you go to log on it wants to do it over https .... this should be changeable in the config ... I would assume but do not know.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 5863
Location: Germany, Next to Hamburg

PostPosted: Mon 15 Feb '10 22:27    Post subject: Reply with quote

glsmith wrote:
but your config, at least the one that got moved to pastebin is incomplete, it is missing all the Include lines near the bottom.


Well I moved it to pastebin, but that was all posted code which was on the forum. Maybe there is / are some includes.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1