logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Making Bugzilla directory "visible" to web.

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
lostpacket



Joined: 22 Oct 2015
Posts: 1

PostPosted: Thu 22 Oct '15 20:31    Post subject: Making Bugzilla directory "visible" to web. Reply with quote

Greetings!
I'm updating this post to say the problem appears to be solved.
Per instructions, I WAS running:
testserver.pl http://localhost

Just tried:
testserver.pl http://localhost/bugzilla
Success!

PREVIOUSLY...:
Greetings!
I'm trying to run Bugzilla under Windows 7, using Apache.

I installed Apache 2.4 and it's serving the "IT WORKS" page, however, [/bugzilla/bin/]testserver.pl is returning:
"
TEST-FAILED Fetch of images/padlock.png failed
Your web-server could not fetch http://localhost/images/padlock.png.
"

Error does not seem to be explained by the "VirtualStore" problem described in Bugzilla docs.

I tried modifying httpd.conf to set SRVROOT to C:/bugzilla, but then Apache wouldn't start.
It seems that files under "C:/Apache24" and "C:/bugzilla" need to be "visible" simultaneously.

I have added the following to httpd.conf:
"
Alias "/bugzilla/" "C:/bugzilla/"
<Directory "C:/bugzilla">
ScriptInterpretorSource Registry-Strict
Options +ExecCGI +FollowSymLinks
DirectoryIndex index.cgi index.html
AllowOverride Limit FileInfo Indexes Options
"
Apache starts but bugzilla test still fails.

Apache does throw (3) ssl-related warnings when booting:
"server certificate does not include an ID which matches the server name" - I don't know if this is important.

Any help is appreciated!

Smile
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Sat 24 Oct '15 13:26    Post subject: Reply with quote

it might be required to run bugzilla in the root. Or you can change the config and define the subfolder url. Or you have to define some more Alias. Where is that image folder located?
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1