logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



The pipe has been ended. : mod_fcgid: get overlap
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Thu 05 Jul '12 3:20    Post subject: Reply with quote

James:

I open the php error long at startup.But,there is no error log shows when startup.

My apache log shows at startup:
Apache/2.2.22 (Win32) mod_fcgid/2.3.7 configured

I use the php5.3.14 thread safe.

But,when I visit the webpage,it shows internal error.And,the apache error log shows:
mod_fcgid: read timeout from pipe And Premature end of script headers: index.php

I am sure the webpage runs good under php5.2.17.

How to solve it? Smile
Back to top
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Fri 06 Jul '12 0:21    Post subject: Reply with quote

I am going crazy.
Can't find the way to solve this yet.

Crying or Very sad
Back to top
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Fri 06 Jul '12 3:37    Post subject: Reply with quote

Is there anyone who install apache 2.2.22+php 5.3.x+mod_fcgid2.3.7 on windows server 32 bit successfully?Can provide some way to fix this issue?

Or mod_fcgid is not suit for php5.3.x vc9?Is it possible to create php 5.3.x vc6?
Back to top
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Fri 06 Jul '12 5:36    Post subject: Reply with quote

gl:

I make serveral tests.
It's a strange thing.

After I upgrade php5.2.17 to php5.3.x,the mod_fcgid: get overlap result error and
Premature end of script headers: index.php error and message shows again and again,even it read phpinfo.php only.

Can you help me to solve this issue,please?

thank in advanced.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Fri 06 Jul '12 5:52    Post subject: Reply with quote

doubtful ... I'm not very good with PHP as it's not very friendly with me.

I had this problem as you can see here
https://www.apachehaus.com/forum/index.php?topic=268.msg1026#msg1026

I'm not quite sure what the problem was ... but I think it was something in my php.ini file. Or, needed to use backslashes \\ in my fcgid.conf file .. or both

5.3.14ts + 2.2.22 + mod_fcgid/2.3.7 is working fine on both Vista & XP these days

EDIT: However, the way to start debugging is usually to start out with NO extensions and just try getting phpinfo() to work. Then add extensions and keep checking as you are adding them.
Back to top
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Fri 06 Jul '12 8:26    Post subject: Reply with quote

gl,

Did you open a webpage when your php5.3.x+mod_fcgid installed?

The apache log indicates mod_fcgid configured already.When you visit a local webpage,the mod_fcgid error message shows.Internal Server Error..etc..

I use the pure php.ini to replace an old one,it shows error still.To install at win7 which gets the same error as win 2003 server.

I run mod_fcgid under php5.4.4 also,it appears the error still.

I hate php too.But,there are many applications written by php.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Fri 06 Jul '12 20:40    Post subject: Reply with quote

maskego wrote:
gl,

Did you open a webpage when your php5.3.x+mod_fcgid installed?


Ja, I have a wiki I keep build notes on and a blog I haven't written to since April 1st.
Back to top
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Sat 07 Jul '12 10:16    Post subject: Reply with quote

I hate php again.

There are so many php scripts can't run under php5.3.x or php5.4.x...But,php 5.2.x will be EOL soon.

What a joke that comes from php.net Crying or Very sad
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Mon 23 Jul '12 11:19    Post subject: Reply with quote

Run multiple versions of php might be a solution

http://www.apachelounge.com/viewtopic.php?t=3430
Back to top
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Thu 26 Jul '12 4:21    Post subject: Reply with quote

Thank for your multiple php version installation way.But,should it to consider the performance and adaptability of mysql version either?

James Blond wrote:
Run multiple versions of php might be a solution

http://www.apachelounge.com/viewtopic.php?t=3430
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Thu 26 Jul '12 11:35    Post subject: Reply with quote

maskego wrote:
But,should it to consider the performance and adaptability of mysql version either?


From PHP side aka mysql driver or MySQL itself? Please explain more.
Back to top
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Sat 28 Jul '12 1:49    Post subject: Reply with quote

I make a try.

Under php5.2.x I upgrade the mysql from 5.0.x to 5.5.x,the connection to mysql get failed unless upgrade to php 5.3.x

That's the question.If installs multiple version of php,it has to install the proper mysql version.


James Blond wrote:
maskego wrote:
But,should it to consider the performance and adaptability of mysql version either?


From PHP side aka mysql driver or MySQL itself? Please explain more.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Sat 28 Jul '12 10:06    Post subject: Reply with quote

maskego wrote:

Under php5.2.x I upgrade the mysql from 5.0.x to 5.5.x,the connection to mysql get failed unless upgrade to php 5.3.x



From PHP 5.3 on PHP uses its own mysql driver (mysqlnd). It is not anymore bound to a mysql version. If you have to use PHP 5.2 than you could use the smallest working MySQL version which will work with the higher PHP versions.

Well it is possible with a Master Master replication to use different MySQL version on different ports. (I for myself have only tried with the same version)
Back to top
maskego



Joined: 16 Apr 2010
Posts: 238

PostPosted: Sun 29 Jul '12 9:39    Post subject: Reply with quote

james:

Could you please write some tips about how to install various version of mysql at different ports? Smile
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Sun 29 Jul '12 11:48    Post subject: Reply with quote

Please open a new thread, the MySQL question is not related to the original subject.

New topic http://www.apachelounge.com/viewtopic.php?p=22201#22201
Back to top
PanchoJ



Joined: 25 Oct 2012
Posts: 11
Location: Australia

PostPosted: Tue 19 Mar '13 23:59    Post subject: Reply with quote

If you are using APC and come across this error I'd suggest you disable APC.
Back to top
japi



Joined: 05 Jan 2013
Posts: 6
Location: Frankfurt

PostPosted: Tue 24 Feb '15 3:29    Post subject: mod_fcgid: get overlap result error Reply with quote

Hey everyone,
sorry for reviving this old thread, but it is the #1 Hit if you google for "mod_fcgid: get overlap result error" - and that's what i just did Very Happy

I just migrated from
php-5.4.11-nts-Win32-VC9-x86 to
php-5.6.6-nts-Win32-VC11-x86
and had this error messages in my websitespecific apache errorlog:
Code:
[Tue Feb 24 00:47:38.728305 2015] [fcgid:warn] [pid 5040:tid 1092] (OS 109)The pipe has been ended.  : [client (IP removed)] mod_fcgid: get overlap result error
[Tue Feb 24 00:47:38.728305 2015] [core:error] [pid 5040:tid 1092] [client (IP removed)] End of script output before headers: index.php


The error was quite easy to find in my case:
When i tried to start php.exe standalone I got an error message, telling me some DLL was missing:
Quote:
The program can't start because MSVCR110.dll is missing from your computer. Try reinstalling the program to fix this problem.

A message I had seen before with other software Very Happy
I just forgot to install the new --> VCRedist package which was required due to the migration from the VC9 to the VC11 build. (doh! - it was linked on the php download page...)
There is always some VCRedist package missing Wink
And with all versions of the package having the same filename it is not a great pleasure to keep track of which ones are already installed Rolling Eyes

Well, installing this package (in the same bitness (x68/x64) as php!) is one more option to fix this problem, so i wanted to share it here, where everyone (including me Mr. Green ) can find it again.

Hope it helps someone Smile

Best regards
Back to top
sikander



Joined: 14 Sep 2017
Posts: 1
Location: .ca .to

PostPosted: Thu 14 Sep '17 14:59    Post subject: Re: mod_fcgid: get overlap result error Reply with quote

japi wrote:
I just forgot to install the new --> VCRedist package which was required due to the migration from the VC9 to the VC11 build. (doh! - it was linked on the php download page...)


Thank you! This fixed the problem for me. I had installed 4 different VCRedists already but missed this particular one.

- windows server 2012
- httpd-2.4.27-ossl11-x64-vc14
- php-5.6.31-Win32-VC11-x64
- mod_fcgid-2.3.9a-2.4.x-x64-vc14

Why Windows Server doesn't automatically include all the VCRedist packages is beyond comprehension.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Tue 31 Oct '17 17:31    Post subject: Re: mod_fcgid: get overlap result error Reply with quote

sikander wrote:

Why Windows Server doesn't automatically include all the VCRedist packages is beyond comprehension.


Because it has to be installed system wide, also it would, if added, blow the download size.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules Goto page Previous  1, 2
Page 2 of 2