logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Experimental: PHP 5.6 and Apache 2.4.10 VC11 for 2K3/XP
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
va2dim



Joined: 23 Mar 2016
Posts: 1
Location: Ukraine

PostPosted: Wed 23 Mar '16 11:59    Post subject: Apache VC11 and PHP 5.6.4 (v110_xp toolset) on WindowsXP Reply with quote

When I tried to install Apache on WinXP SP3 (httpd.exe -k install) from this compilation came Error of application initialization (0xC0150002).

Redistributed packet of Visual C++ for Visual Studio 2012 Update 4 was installed previously.

Please help to go through this problem.

Jan-E wrote:
There was a lot of talk lately around the performance of Apache+PHP on Windows. One of the remarks that intrigued me was that PHP performance on Windows 2003 has been (or still is) a lot better than on Windows 2008 or 2013. My laptop is dual boot (XP SP3 and Windows 7), so I investigated if the same difference was present between Win7 and XP. Long story, short: XP surely is not slower and maybe a little faster. This is a copy of my setup of Apache VC11 and PHP 5.6.4 (with v110_xp toolset) on Windows XP:

https://phpdev.toolsforresearch.com/ApacheVC11_with_PHP564_on_XP.htm

I had to make some very experimental builds of Apache and PHP 5.6.4:

https://phpdev.toolsforresearch.com/Apache24.v110_xp.zip
https://phpdev.toolsforresearch.com/php-5.6.4-Win32-VC11-x86-xp.zip
https://phpdev.toolsforresearch.com/php-5.6.4-nts-Win32-VC11-x86-xp.zip

Play with it, do not use in in production and post your config with the best performance.
Back to top
mielhore



Joined: 09 Feb 2017
Posts: 1

PostPosted: Thu 09 Feb '17 22:46    Post subject: New PHP 5.6 for XP Reply with quote

I have come across this topic in Google but I couldn't get these to builds work on my system (XP x64 SP2). However, I found someone else has ported PHP 5.6.24:

https://github.com/ProgerXP/php-5.6-xp

I tested it on XAMPP Lite 1.8.1:

https://sourceforge.net/projects/xampp/files/XAMPP%20Windows/1.8.1/

Works like a charm. I just swapped the php folder in my XAMPP installation from php4xampp.zip and commented out all extension=... lines in php.ini except for curl and fileinfo. Works on the Apache from XAMPP (Apache version 2.4.3).

php -v:

Code:
PHP 5.6.24 (cli) (built: Oct  6 2016 08:55:15)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies


List of extensions:

Code:
bz2
calendar
Core
ctype
curl
date
dom
ereg
exif
fileinfo
filter
gd
gettext
gmp
hash
iconv
json
libxml
mbstring
mcrypt
mysql
mysqli
mysqlnd
openssl
pcre
PDO
pdo_mysql
pdo_pgsql
pdo_sqlite
pgsql
Phar
Reflection
session
SimpleXML
sockets
SPL
sqlite3
standard
tokenizer
xml
xmlreader
xmlrpc
xmlwriter
zip
zlib
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Mon 26 Mar '18 19:23    Post subject: Reply with quote

The only thing i get on windows server 2003 32 bit (all updates installed) is the following message when i execute httpd.exe:

"The appplication failed to initialize properly (0xc01500002). Click on OK to terminate the application."

MSVC11 runtime is installed!

What's the problem, does somebody know??

Thanks in advance!!!
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Mon 26 Mar '18 20:52    Post subject: Reply with quote

Quote:
"very experimental"


Oh... but in my opinion, it's not "very experimental", it's just a waste of time if it don't work on a freshly installed windows server 2003 32 bit installation (all updated from m$ installed and msvc11 runtime update 4)

mielhore's solution works very well, thank you mielhore!! Smile
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 887
Location: Amsterdam, NL, EU

PostPosted: Tue 27 Mar '18 2:33    Post subject: Reply with quote

Out of curiosity, I checked if it still worked on my WinXP SP3. It did:

Code:
D:\phpdev\php-5.6.4-Win32-VC11-x86-xp>ver

Microsoft Windows XP [Version 5.1.2600]

D:\phpdev\php-5.6.4-Win32-VC11-x86-xp>\phpdev\Apache24.v110_xp\bin\httpd -n Apache24.v110_xp -k install
Installing the Apache24.v110_xp service
The Apache24.v110_xp service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.

D:\phpdev\php-5.6.4-Win32-VC11-x86-xp>php -v
PHP 5.6.4 (cli) (built: Jan  3 2015 21:03:55)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2014, by Zend Technologies
    with Xdebug v2.2.6, Copyright (c) 2002-2014, by Derick Rethans

D:\phpdev\php-5.6.4-Win32-VC11-x86-xp>php -m
[PHP Modules]
bcmath
blenc
bz2
calendar
com_dotnet
Core
crypto
ctype
curl
date
dba
dbase
dio
discount
dom
doublemetaphone
ereg
event
excel
exif
fileinfo
filter
fribidi
ftp
gd
gender
geoip
gettext
gmp
haru
hash
hrtime
htscanner
http
iconv
igbinary
imap
interbase
intl
jsmin
json
judy
ldap
libxml
lzf
mailparse
mbstring
mcrypt
mdbtools
mhash
mongo
msgpack
mysql
mysqli
mysqlnd
OAuth
odbc
openssl
PC/SC
pcre
PDO
pdo_mysql
PDO_ODBC
pdo_sqlite
Phar
pop3
printer
propro
pspell
pthreads
radius
raphf
rar
redis
Reflection
rsync
session
shmop
SimpleXML
smtp
soap
sockets
solr
SPL
sqlite3
ssdeep
ssh2
standard
stats
Stomp
svn
sync
tidy
timezonedb
tokenizer
translit
uploadprogress
uprofiler
varnish
wddx
wfio
win32ps
xdebug
xml
xmldiff
xmlreader
xmlrpc
xmlwriter
xsl
xslcache
Zend OPcache
zip
zlib

[Zend Modules]
Xdebug
Zend OPcache


I had to copy the libapr*.dll from the Apache's bin directory to the PHP directory, disable a few modules in the php.ini (but most of the worked, as you can see).
Code:
extension_dir = "/phpdev/php-5.6.4-Win32-VC11-x86-xp/ext"


Settings at the end of httpd.conf:
Code:
<IfModule alias_module>
   <IfModule mime_module>
      PHPINIDir "/phpdev/php-5.6.4-Win32-VC11-x86-xp/"
      LoadModule php5_module "/phpdev/php-5.6.4-Win32-VC11-x86-xp/php5apache2_4.dll"
      AddType text/html .php
      <FilesMatch "\.php$">
         SetHandler application/x-httpd-php
      </FilesMatch>
      <FilesMatch "\.phps$">
         SetHandler application/x-httpd-php-source
      </FilesMatch>
   </IfModule>
</IfModule>


Resulting phpinfo():
https://phpdev.toolsforresearch.com/apache24.v110_xp.html


Last edited by Jan-E on Tue 27 Mar '18 3:20; edited 1 time in total
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 887
Location: Amsterdam, NL, EU

PostPosted: Tue 27 Mar '18 2:50    Post subject: Reply with quote

jmar83 wrote:
"The appplication failed to initialize properly (0xc01500002). Click on OK to terminate the application."

0xc01500002 means you are missing a MSVC runtime. On my XP I have probably installed them all: VC9, VC10, VC11 and maybe even earlier than VC9.
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Sat 31 Mar '18 15:36    Post subject: Reply with quote

thx!!
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Sat 31 Mar '18 15:38    Post subject: Reply with quote

the 3 compiled extensions from "php-5.6-xp" are not working too: https://github.com/ProgerXP/php-5.6-xp/issues/4
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Sat 31 Mar '18 15:55    Post subject: Reply with quote

@Jan-E: All MSVC Runtime Libraries are installed:



Maybe they are not the most current ones? So i know, there are some updates for some MSVC Runtime Libraries...?
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Sat 31 Mar '18 16:23    Post subject: Reply with quote

the only one which is not most current is 2010 runtime, i use 10.0.40219 instead of 10.0.40219.325

https://blogs.technet.microsoft.com/jagbal/2017/09/04/where-can-i-download-the-old-visual-c-redistributables/

but the .325 just seems to be a security patch..?

however, will try it now..
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Sat 31 Mar '18 16:28    Post subject: Reply with quote

so it seems i have the .325 version installed, but windows server 2003 control panel does not show .325 at the end. (hmmm...)

When i click the setup file, i get an repair- or uninstall option, which means it's already installed in my opinion.

-> Maybe it's a problem/conflict with another php/apache installation, will investigate now..
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Sat 31 Mar '18 17:51    Post subject: Reply with quote

problem solved by using your extensions with https://github.com/ProgerXP/php-5.6-xp/issues/4

(yes, some of them are compatible v. 5.6.4.0 vs. v. 5.6.24)
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 887
Location: Amsterdam, NL, EU

PostPosted: Sun 01 Apr '18 5:32    Post subject: Reply with quote

Maybe some of the dependent DLL's were v140_xp.

Or maybe you had the same path issue as in https://github.com/ProgerXP/php-5.6-xp/issues/4#issuecomment-377695382 when you tested my experimental build.



Glad to know the experimental build was not a "waste of time" after all.
Back to top
jmar83



Joined: 10 Mar 2018
Posts: 11

PostPosted: Wed 04 Apr '18 18:32    Post subject: Reply with quote

"but windows server 2003 control panel does not show .325 at the end. "

Yes, i've verified that now... i uninstalled the existing packge, then re-installed with the .325 version - will not be shown in the windows server 2003 control panel...
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads Goto page Previous  1, 2
Page 2 of 2