logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



httpd 2.4.34/35 with Openssl 1.1.1

 
Post new topic   Reply to topic    Apache Forum Index -> News & Hangout



View previous topic :: View next topic  
Author Message
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2690
Location: Hilversum, NL, EU

PostPosted: Wed 12 Sep '18 11:39    Post subject: httpd 2.4.34/35 with Openssl 1.1.1 Reply with quote

Openssl.org says that the new 1.1.1 is binary and API compatible with OpenSSL 1.1.0.

I tested it here, and indeed it gives no troubles.

Maybe you can give it also a try, when no issues then we drop the downloads with 1.1.0.

Download removed: download 2.4.35 (vote) has 1.1.1

Note:
Apache 2.4.34 does not support yet TLSv1.3, expected in 2.4.36 release.

In the downloads also updated APR to 1.6.5, expat to 2.2.6, nghttp2 to 1.33.0 and curl 7.61.1.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2690
Location: Hilversum, NL, EU

PostPosted: Thu 20 Sep '18 10:45    Post subject: Reply with quote

We are not going to ship 2.4.35 with OpenSSL 1.1.1


On the dev list is an issue reported:

The flipped setting of SSL_MODE_AUTO_RETRY
is expected to break TLSv1.2 as well.

So to be on the save side, we do not ship 1.1.1
Back to top


Post new topic   Reply to topic    Apache Forum Index -> News & Hangout
Page 1 of 1