logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Start apache libphp5.so error

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
catiewong



Joined: 26 Nov 2018
Posts: 3
Location: hong kong

PostPosted: Mon 26 Nov '18 11:43    Post subject: Start apache libphp5.so error Reply with quote

I have installed httpd-2.4.12 on centos 7.5 with tar.gz , the php 5.6.9 is also installed by tar.gz , after installed the httpd , it pops the following error when startup , would suggest what would be the possible reason of this error ? thanks


httpd: Syntax error on line 185 of /usr/local/apache2/conf/httpd.conf: Cannot load modules/libphp5.so into server: /usr/local/apache/modules/libphp5.so: undefined symbol: XpmLibraryVersion
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 887
Location: Amsterdam, NL, EU

PostPosted: Tue 27 Nov '18 9:58    Post subject: Reply with quote

Try installing libXpm-devel:
# sudo yum install libXpm-devel
Back to top
catiewong



Joined: 26 Nov 2018
Posts: 3
Location: hong kong

PostPosted: Tue 27 Nov '18 11:53    Post subject: Reply with quote

Jan-E wrote:
Try installing libXpm-devel:
# sudo yum install libXpm-devel


Installed , fail to run

# yum install libXpm-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.nethub.com.hk
* epel: fedora.cs.nctu.edu.tw
* extras: centos.nethub.com.hk
* updates: centos.nethub.com.hk
Package libXpm-devel-3.5.12-1.el7.x86_64 already installed and latest version
Back to top
catiewong



Joined: 26 Nov 2018
Posts: 3
Location: hong kong

PostPosted: Tue 27 Nov '18 13:21    Post subject: Reply with quote

Just would like to ask , if I find any library files are missing , is it ok to copy it from another machines ( with the similar version ) ?
Back to top
maba



Joined: 05 Feb 2012
Posts: 60
Location: Germany, Heilbronn

PostPosted: Thu 29 Nov '18 9:03    Post subject: Reply with quote

#1 I would propose not to install an outdated version via tar.gz. The only reason I could see for the tar.gz install is if you want a newer version than what CentOS provides

#2 MUST MATCH: the Apache API version and the libphp version must be compatible (use the same Apache module API version)

#3 Strong proposal:
- remove the manual installation
- replace with
"sudo yum install httpd" and
"sudo yum install php"

If you want a newer PHP version:

https://tecadmin.net/install-php-7-on-centos/
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6484
Location: Germany, Next to Hamburg

PostPosted: Mon 10 Dec '18 12:10    Post subject: Reply with quote

For from scratch you can use https://github.com/JBlond/debian_build_apache24/ (works also on CentOS)

But I recommend to install php via yum
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1