logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Subversion and mod_dav/authz_svn 1.10.4
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
spser



Joined: 29 Aug 2016
Posts: 57

PostPosted: Sun 09 Jul '17 8:29    Post subject: Reply with quote

ssleay32.dll
libeay32.dll


apache/bin

The document turned out to be.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Sun 09 Jul '17 9:06    Post subject: Reply with quote

It does not matter. it runs with both versions. You can put back the original Apachehaus dll's if you want to be sure.
Back to top
spser



Joined: 29 Aug 2016
Posts: 57

PostPosted: Sun 09 Jul '17 10:12    Post subject: Reply with quote

Thank you. I'm Chinese
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Fri 11 Aug '17 2:18    Post subject: Reply with quote

There is a security release for subversion:
http://mail-archives.apache.org/mod_mbox/subversion-dev/201708.mbox/<2fefe468-7d41-11e7-aea1-9312c6089150%40apache.org>
http://mail-archives.apache.org/mod_mbox/subversion-dev/201708.mbox/<1502392906.1289398.1069601624.115A8A62%40webmail.messagingengine.com>

I am rebuilding subversion with the apache modules.

Code:
Generating for Visual Studio 2015 / 2012 / 2008

Could not find installed SWIG
Found apr 1.6.2
Found apr-util 1.6.0
Found apr_memcache 1.6.0
Found expat 2.2.1
Found httpd 2.4.27
Found mod_dav 2.4.27
Found openssl 1.0.2l
Found sasl 2.1.27
Found serf 1.3.9
Found sqlite 3.19.3
Found zlib 1.2.11
swig not found; skipping SWIG file generation...

https://phpdev.toolsforresearch.com/mod_svn-1.9.7-ap24-x64-vc14.zip
https://phpdev.toolsforresearch.com/mod_svn-1.9.7-ap24-x64-vc11.zip
https://phpdev.toolsforresearch.com/mod_svn-1.9.7-ap24-x64-vc9.zip

https://phpdev.toolsforresearch.com/mod_svn-1.9.7-ap24-x86-vc14.zip
https://phpdev.toolsforresearch.com/mod_svn-1.9.7-ap24-x86-vc11.zip
https://phpdev.toolsforresearch.com/mod_svn-1.9.7-ap24-x86-vc9.zip
Back to top
tadoc



Joined: 08 May 2018
Posts: 4
Location: Japan, kanagawa

PostPosted: Wed 09 May '18 7:07    Post subject: Reply with quote

mod_svn-1.9.7-ap24-x64-vc11.zip is working good!
And I'm waiting new subversion-1.10 of vc11 or vc14.
Thank you.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Fri 11 May '18 16:13    Post subject: Reply with quote

Generating for Visual Studio 2012/2015

Could not find installed SWIG
Found apr 1.6.3
Found apr-util 1.6.1
Found apr_memcache 1.6.1
Found expat 2.2.5
Found httpd 2.4.33
Found mod_dav 2.4.33
Found openssl 1.0.2o
Found sasl 2.1.27
Found serf 1.3.9
Found sqlite 3.23.1
Found zlib 1.2.8/11
Using bundled lz4 1.7.5
Using bundled utf8proc 2.1.0
swig not found; skipping SWIG file generation...

Summary of test results:
2366 tests PASSED
121 tests SKIPPED
50 tests XFAILED (1 WORK-IN-PROGRESS)
SUMMARY: All tests successful.

https://phpdev.toolsforresearch.com/mod_svn-1.10.0-VC14-x64.zip
https://phpdev.toolsforresearch.com/mod_svn-1.10.0-VC14-x86.zip
https://phpdev.toolsforresearch.com/mod_svn-1.10.0-VC11-x64.zip
https://phpdev.toolsforresearch.com/mod_svn-1.10.0-VC11-x86.zip
https://phpdev.toolsforresearch.com/mod_svn-1.10.0-VC9-x64.zip
https://phpdev.toolsforresearch.com/mod_svn-1.10.0-VC9-x86.zip


Last edited by Jan-E on Sat 12 May '18 14:06; edited 1 time in total
Back to top
spser



Joined: 29 Aug 2016
Posts: 57

PostPosted: Fri 11 May '18 18:32    Post subject: Reply with quote

Apache/2.4.33 (Win64) mod_fcgid/2.3.9 OpenSSL/1.1.0h PHP/7.2.4 SVN/1.10.0 Server at 127.0.0.1 Port 80

thx,
Back to top
tadoc



Joined: 08 May 2018
Posts: 4
Location: Japan, kanagawa

PostPosted: Mon 14 May '18 1:43    Post subject: Reply with quote

Jan-E, thank you for your quick response.
I will try ver.1.10.0 soon.
Back to top
sridharb



Joined: 09 Jun 2010
Posts: 6

PostPosted: Tue 18 Sep '18 8:46    Post subject: 1.10.2? Reply with quote

Hi Jan-E,

When you get the chance, could you please update the binaries to 1.10.2 (or the latest stable at that time)?

Thanks,
Sridhar
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Thu 20 Sep '18 20:25    Post subject: Reply with quote

Generating for Visual Studio 2008/2012/2015/2017

Could not find installed SWIG
Found apr 1.6.5
Found apr-util 1.6.1
Found apr_memcache 1.6.1
Found expat 2.2.6
Found httpd 2.4.35
Found mod_dav 2.4.35
Found openssl 1.0.2p
Found sasl 2.1.25
Found serf 1.3.9
Found sqlite 3.23.1
Found zlib 1.2.8
Using bundled lz4 1.7.5
Using bundled utf8proc 2.1.0
swig not found; skipping SWIG file generation...

Summary of test results:
2369 tests PASSED
121 tests SKIPPED
50 tests XFAILED (1 WORK-IN-PROGRESS)
SUMMARY: All tests successful.

https://phpdev.toolsforresearch.com/svn-1.10.2-vc15.x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.2-vc15.x86.zip
https://phpdev.toolsforresearch.com/svn-1.10.2-vc14.x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.2-vc14.x86.zip
https://phpdev.toolsforresearch.com/svn-1.10.2-vc11.x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.2-vc11.x86.zip
https://phpdev.toolsforresearch.com/svn-1.10.2-vc9.x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.2-vc9.x86.zip
Back to top
tadoc



Joined: 08 May 2018
Posts: 4
Location: Japan, kanagawa

PostPosted: Mon 03 Dec '18 2:45    Post subject: Reply with quote

Jan-E, Thank you.
1.10.2 for VC15 is working good!
Back to top
spser



Joined: 29 Aug 2016
Posts: 57

PostPosted: Mon 03 Dec '18 4:01    Post subject: Reply with quote

1.10.3 / apache?
Back to top
tadoc



Joined: 08 May 2018
Posts: 4
Location: Japan, kanagawa

PostPosted: Wed 30 Jan '19 4:39    Post subject: Reply with quote

I'm looking forward to updating to ver.1.11.1.

Thanks,
tadoc
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Sun 03 Feb '19 19:50    Post subject: Reply with quote

Generating for Visual Studio 2017

Could not find installed SWIG
Found apr 1.6.5
Found apr-util 1.6.1
Found apr_memcache 1.6.1
Found expat 2.2.6
Found httpd 2.4.38
Found mod_dav 2.4.38
Found openssl 1.1.1a
Found sasl 2.1.27
Found serf 1.3.9
Found sqlite 3.26.0
Found zlib 1.2.11
Using bundled lz4 1.7.5
Using bundled utf8proc 2.1.0
swig not found; skipping SWIG file generation...

Summary of test results:
2382 tests PASSED
123 tests SKIPPED
50 tests XFAILED (1 WORK-IN-PROGRESS)
SUMMARY: All tests successful.

https://phpdev.toolsforresearch.com/svn-1.10.4-vc15-x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc15-x86.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc14-openssl-1.1.1-x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc14-openssl-1.1.1-x86.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc14-x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc14-x86.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc11-x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc11-x86.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc9-x64.zip
https://phpdev.toolsforresearch.com/svn-1.10.4-vc9-x86.zip
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 978
Location: Amsterdam, NL, EU

PostPosted: Sun 03 Feb '19 19:55    Post subject: Reply with quote

tadoc wrote:
I'm looking forward to updating to ver.1.11.1.

I prefer building the LTS versions. nono303 has the 1.11.1 ones:
https://www.apachelounge.com/viewtopic.php?t=7951

We fixed a bug in apr_crypto_openssl.dll:
https://github.com/nono303/win-svn/issues/3
Back to top
AntonWert



Joined: 30 Mar 2019
Posts: 1
Location: Germany, Dewangen

PostPosted: Sat 30 Mar '19 18:36    Post subject: Need help: mod_svn creates forbidden or restarts of apache Reply with quote

Hello,

I used the mod_dav_svn.so and mod_authz_svn.so quite a long time. It worked fine on a Windows Server 2012, together with PHP

Recently I updated Apache and PHP to the versions:
Apache 2.4.38 (x86)
PHP 7.3.3 (x86)

Everything worked fine, except the Web-Access to the SVN reprositorys was broken (but via Tortoise SVN still available without any problems). With broken I mean there was simply no page displayed.

Recently I found this post, and installed the latest Version of the modules.
svn-1.10.4-vc15-x86.zip
I installed everything (mods and SVN.xx files) in one Sub directory of Apache. No Problem at all. Server is running.


But when I want now to access via Tortoise SVN I get "forbidden" (403). Even with a minimalistic svnaccessfile, or completely disabled

Code:

[/]
* = rw


inside my httpd.conf I have this secion:
Code:

<Location /svn/>
DAV svn
SVNListParentPath on
SVNParentPath "K:\repos"
#SVNIndexXSLT "/svnindex.xsl"
#AuthType Basic
#AuthType SSPI
#AuthName "ee-tool"
#AuthUserFile "C:\Apache24\passwd"
#AuthzSVNAccessFile "C:\\Apache24\svnaccessfile"
#Require valid-user
</Location>


Even more interesting is the Web Access: The parent path is browsable as "normal" but if I click inside the reporsitory no page is delivered and for me, the Server seems to have restarted.
Within secons there are several Messages in the error.log
Code:

[Sat Mar 30 17:04:17.007866 2019] [ssl:warn] [pid 6812:tid 928] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Mar 30 17:04:17.008762 2019] [ssl:warn] [pid 6812:tid 928] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:17.017795 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00455: Apache/2.4.38 (Win32) OpenSSL/1.1.1b SVN/1.10.4 PHP/7.3.3 configured -- resuming normal operations
[Sat Mar 30 17:04:17.018762 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00456: Apache Lounge VC15 Server built: Feb 28 2019 11:00:29
[Sat Mar 30 17:04:17.018762 2019] [core:notice] [pid 6812:tid 928] AH00094: Command line: 'C:\\Apache24\\bin\\httpd.exe -d C:/Apache24'
[Sat Mar 30 17:04:17.020762 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00418: Parent: Created child process 15572
[Sat Mar 30 17:04:17.419761 2019] [ssl:warn] [pid 15572:tid 864] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:17.435776 2019] [ssl:warn] [pid 15572:tid 864] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Mar 30 17:04:17.436762 2019] [ssl:warn] [pid 15572:tid 864] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:17.984811 2019] [mpm_winnt:notice] [pid 15572:tid 864] AH00354: Child: Starting 64 worker threads.
[Sat Mar 30 17:04:20.805750 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00428: Parent: child process 15572 exited with status 3228369022 -- Restarting.
[Sat Mar 30 17:04:20.826784 2019] [ssl:warn] [pid 6812:tid 928] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Mar 30 17:04:20.827769 2019] [ssl:warn] [pid 6812:tid 928] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:20.837767 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00455: Apache/2.4.38 (Win32) OpenSSL/1.1.1b SVN/1.10.4 PHP/7.3.3 configured -- resuming normal operations
[Sat Mar 30 17:04:20.837767 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00456: Apache Lounge VC15 Server built: Feb 28 2019 11:00:29
[Sat Mar 30 17:04:20.837767 2019] [core:notice] [pid 6812:tid 928] AH00094: Command line: 'C:\\Apache24\\bin\\httpd.exe -d C:/Apache24'
[Sat Mar 30 17:04:20.839771 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00418: Parent: Created child process 5892
[Sat Mar 30 17:04:21.234797 2019] [ssl:warn] [pid 5892:tid 852] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:21.251743 2019] [ssl:warn] [pid 5892:tid 852] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Mar 30 17:04:21.251743 2019] [ssl:warn] [pid 5892:tid 852] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:21.262745 2019] [mpm_winnt:notice] [pid 5892:tid 852] AH00354: Child: Starting 64 worker threads.
[Sat Mar 30 17:04:25.009072 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00428: Parent: child process 5892 exited with status 3228369022 -- Restarting.
[Sat Mar 30 17:04:25.032071 2019] [ssl:warn] [pid 6812:tid 928] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Mar 30 17:04:25.033071 2019] [ssl:warn] [pid 6812:tid 928] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:25.043074 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00455: Apache/2.4.38 (Win32) OpenSSL/1.1.1b SVN/1.10.4 PHP/7.3.3 configured -- resuming normal operations
[Sat Mar 30 17:04:25.043074 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00456: Apache Lounge VC15 Server built: Feb 28 2019 11:00:29
[Sat Mar 30 17:04:25.043074 2019] [core:notice] [pid 6812:tid 928] AH00094: Command line: 'C:\\Apache24\\bin\\httpd.exe -d C:/Apache24'
[Sat Mar 30 17:04:25.046070 2019] [mpm_winnt:notice] [pid 6812:tid 928] AH00418: Parent: Created child process 15804
[Sat Mar 30 17:04:25.446080 2019] [ssl:warn] [pid 15804:tid 880] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:25.473131 2019] [ssl:warn] [pid 15804:tid 880] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Mar 30 17:04:25.474105 2019] [ssl:warn] [pid 15804:tid 880] AH01909: peter:443:0 server certificate does NOT include an ID which matches the server name
[Sat Mar 30 17:04:25.486071 2019] [mpm_winnt:notice] [pid 15804:tid 880] AH00354: Child: Starting 64 worker threads.


I now veryfied the exactly same behaviour on a Win10 PC.

Has anyone the same experiance?
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads Goto page Previous  1, 2
Page 2 of 2