logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: Module compatibility from Apache 2.0.59 to Apache 2.2
Author
JayChandler



Joined: 18 Apr 2019
Posts: 1
Location: Austria,Wels

PostPosted: Thu 18 Apr '19 10:24    Post subject: Module compatibility from Apache 2.0.59 to Apache 2.2 Reply with quote

Hello

I need to upgrade an old Apache 2.0.59 to a newer 2.2 version. My problem is that we have an old legacy module which we need to migrate too. We don't have the sources of this module Crying or Very sad

Is there any chance this module will run in an Apache 2.2 ?

Thx
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6676
Location: Germany, Next to Hamburg

PostPosted: Thu 18 Apr '19 13:17    Post subject: Reply with quote

Nope.
there is something that is called magic number in the code and that module will not run.
No chance without the source code and compiling it against 2.2.

Note that 2.2 is End-of-Life. So you better upgrade to 2.4 if you can.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2767
Location: Hilversum, NL, EU

PostPosted: Thu 18 Apr '19 17:40    Post subject: Reply with quote

With a 2.4.xx reverse proxy to the 2.0.59 you can use the pages which uses the old module. So you have the all new 2.4 stuff in front.
Back to top


Reply to topic   Topic: Module compatibility from Apache 2.0.59 to Apache 2.2 View previous topic :: View next topic
Post new topic   Forum Index -> Apache