logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: Apache httpd 2.4.38 fails to start after 1903 update
Author
mdeggers



Joined: 25 May 2019
Posts: 3
Location: Huntington Beach

PostPosted: Sat 25 May '19 22:27    Post subject: Apache httpd 2.4.38 fails to start after 1903 update Reply with quote

Environment:

Windows 10 Professional 64 bit

Prior to updating to the May 1903 update, Apache HTTPD 2.4.38 was running happily as a service. I use it for development work.

The service was installed with httpd.exe -k install run from an Administrator PowerShell prompt.

Since the update, the service doesn't start. I see the following in the event log.

Faulting application name: httpd.exe, version: 2.4.38.0, time stamp: 0x5c41d445
Faulting module name: ADVAPI32.dll, version: 10.0.18362.1, time stamp: 0x96f604e5
Exception code: 0xc0000005
Fault offset: 0x000000000004bc09
Faulting process id: 0x3b98
Faulting application start time: 0x01d513370d6f1e0a
Faulting application path: D:\Apache24\bin\httpd.exe
Faulting module path: C:\WINDOWS\System32\ADVAPI32.dll
Report Id: 8f77ee94-617c-457b-b76c-26f8bd0d4cb3
Faulting package full name:
Faulting package-relative application ID:

From the details pane:

httpd.exe
2.4.38.0
5c41d445
ADVAPI32.dll
10.0.18362.1
96f604e5
c0000005
000000000004bc09
3b98
01d513370d6f1e0a
D:\Apache24\bin\httpd.exe
C:\WINDOWS\System32\ADVAPI32.dll
8f77ee94-617c-457b-b76c-26f8bd0d4cb3

Pretty much every authenticated user has full control over the directory tree.

I get error 1067 when I attempt to start the service manually.

I have also turned off my antivirus (Avast!). This did not change the results.

I have also tried the recently released 2.4.39 built with VS16. Same results (with different names, of course).

Any help would be greatly appreciated.
Back to top
mdeggers



Joined: 25 May 2019
Posts: 3
Location: Huntington Beach

PostPosted: Sun 26 May '19 20:19    Post subject: Reply with quote

This may be a PHP issue.

I commented out the PHP and mod_jk configurations in my httpd.conf file, and httpd.exe ran properly from the command line.

I reintroduced mod_jk and while httpd.exe started properly, it would not exit from the command line with Ctrl-C. I had to kill the PowerShell window in order for the server to exit.

I will do the following and post back:

1. See if there is an updated mod_jk to address the Ctrl-C issue.

2. See if there is an updated PHP. I'm currently running:

PHP 7.3.1 (cli) (built: Jan 9 2019 22:20:52) ( ZTS MSVC15 (Visual C++ 2017) x64 )

I see that there is a new version.
Back to top
mdeggers



Joined: 25 May 2019
Posts: 3
Location: Huntington Beach

PostPosted: Sun 26 May '19 20:31    Post subject: Reply with quote

There is no later version of mod_jk. However, httpd.exe does exit given enough time when Ctrl-C is pressed.

There is a later version of PHP (7.3.5). Including its configuration in httpd.conf prevents httpd.exe from starting.

At this point I should probably be posting in the PHP forums.
Back to top
MeSo2



Joined: 28 Apr 2016
Posts: 11

PostPosted: Tue 06 Aug '19 0:15    Post subject: Reply with quote

I had to reinstall Apache to 2.4.39 and PHP to 7.3.8, and that fixed it.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6684
Location: Germany, Next to Hamburg

PostPosted: Tue 06 Aug '19 9:14    Post subject: Re: Apache httpd 2.4.38 fails to start after 1903 update Reply with quote

mdeggers wrote:

Exception code: 0xc0000005


c0000005 is an access violation.

Files on a network share? Also possible is that one of the modules you use needs Admin permissions. When ever I have to run Apache as a load balancer some of the memory module require Admin permissions.
Back to top


Reply to topic   Topic: Apache httpd 2.4.38 fails to start after 1903 update View previous topic :: View next topic
Post new topic   Forum Index -> Apache