logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Other Software View previous topic :: View next topic
Reply to topic   Topic: redis or memcache(d)
Author
sailor



Joined: 17 Apr 2015
Posts: 25
Location: US

PostPosted: Tue 10 Sep '19 12:20    Post subject: redis or memcache(d) Reply with quote

I have Wordpress running and trying to get LiteSpeed cache plugin working. I tried memcache (seems to be quite a bit of confusion or looseness in whether it's memcache or memcached) getting litespeed to use it. But, it doesn't recognize it's there. One of the odd things on the plugin page it states that litespeed doesn't work unless you use their web server. Yet, when you look at a web page, it has their branding on it that it was optimized.

So, I tried redis, but it seems to be a dead on Windows and inforation is very slim. I cannot get it loaded in php 7.3.9 (phpinfo page doesn't show it). I tried various dll versions from https://pecl.php.net/package/redis. I did come across someone stating that igbinary also needed to be enabled, but that didn't help.

Any know what might be wrong?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6660
Location: Germany, Next to Hamburg

PostPosted: Wed 11 Sep '19 13:34    Post subject: Reply with quote

I use redis[1]. Yes, it is not the latest version, but it works fine.
For php I use x64 Thread safe 7.3 [2] with the redis 4.2 driver [3]

I also changed the session handler from files to redis

Code:

[Session]
; Handler used to store/retrieve data.
; http://php.net/session.save-handler
session.save_handler = redis
session.save_path = "tcp://127.0.0.1:6379"



[1] https://github.com/microsoftarchive/redis/releases/download/win-3.0.504/Redis-x64-3.0.504.msi

[2] https://windows.php.net/downloads/releases/php-7.3.9-Win32-VC15-x64.zip

[3] https://windows.php.net/downloads/pecl/releases/redis/4.2.0/php_redis-4.2.0-7.3-ts-vc15-x64.zip
Back to top
sailor



Joined: 17 Apr 2015
Posts: 25
Location: US

PostPosted: Wed 11 Sep '19 19:41    Post subject: Reply with quote

Thank you, those settings definitely helped. But I also found another blunder, my php.ini was looking at a prior extension dir version of php.

It seems to be working ok now.

Code:

extension=igbinary
extension=redis
session.save_handler = redis
session.save_path = "tcp://127.0.0.1:6379"
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6660
Location: Germany, Next to Hamburg

PostPosted: Thu 12 Sep '19 11:29    Post subject: Reply with quote

make sure that you always have the full path in the extension dir settings

e.g.
Code:

extension_dir = "C:\php73\ext"
Back to top


Reply to topic   Topic: redis or memcache(d) View previous topic :: View next topic
Post new topic   Forum Index -> Other Software