logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: subdomain not working with https but works with http
Author
edwardsmarkf



Joined: 20 Feb 2013
Posts: 18
Location: cottonwood, az

PostPosted: Wed 20 Nov '19 17:40    Post subject: subdomain not working with https but works with http Reply with quote

hello - i am trying to use a subdomain. it is working fine like this with just http://

http://subdomain.mydomain.com

but it is not working using https://

https://subdomain.mydomain.com

here is my [dot]access file:

Code:

RewriteRule ^subdomain https://mydomain.com/myScript.php       [L]
.....................................
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1%{REQUEST_URI} [R=301,QSA,NC,L]
RewriteCond     %{HTTPS} off
RewriteRule     ^(.*)$  https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]


i suspect the solution is something very simple.

suggestions?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6684
Location: Germany, Next to Hamburg

PostPosted: Mon 25 Nov '19 18:17    Post subject: Reply with quote

What does it mean it is not working?

Do you have two virtual hosts? One for port 80 and one for port 443 with SSL certs?
Back to top
edwardsmarkf



Joined: 20 Feb 2013
Posts: 18
Location: cottonwood, az

PostPosted: Wed 27 Nov '19 15:14    Post subject: Reply with quote

yes i have two virtual servers. port 80 redirects to 443.

when i try to bring up the https:// page i see the following:

-------------------------------------------
This site canít be reached

subdomain.mydoman.com refused to connect.

Try:

Checking the connection
Checking the proxy and the firewall

ERR_CONNECTION_REFUSED
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6684
Location: Germany, Next to Hamburg

PostPosted: Thu 28 Nov '19 5:36    Post subject: Reply with quote

did you try a port scan from external? Did you configure a port forwarding?
Back to top


Reply to topic   Topic: subdomain not working with https but works with http View previous topic :: View next topic
Post new topic   Forum Index -> Apache