logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> News & Hangout View previous topic :: View next topic
Reply to topic   Topic: Dropping VC14 buids !
Author
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2821
Location: Hilversum, NL, EU

PostPosted: Sun 16 Feb '20 12:03    Post subject: Dropping VC14 buids ! Reply with quote

Here at ApacheLounge we follow the VC versions in line with supported PHP releases.

PHP 7.1 is End Of life, see https://www.php.net/supported-versions.php

Support for PHP 7.1 was expired on December 1, 2019. While active support was discontinued a year earlier, the developers continued to deliver security updates in recent months to prevent users from becoming victims of cyberattacks. However, this support is now also being phased out.

PHP 7.1 is build with VC14, so we can drop ??

You can upgrade to VS16/VC15 without issues, it is advised. For example if you want to stay on 7.1 and run as module.

See also the post about: Compatibility VS16/VC15/VC14 .

What do you think ?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6742
Location: Germany, Next to Hamburg

PostPosted: Mon 17 Feb '20 20:11    Post subject: Reply with quote

You can drop the support. With mod_fcgi it is still possible to run older versions if needed. Also PHP 8 is on its way.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2821
Location: Hilversum, NL, EU

PostPosted: Wed 18 Mar '20 13:15    Post subject: Reply with quote

Only one reply.

Can we conclude that there is no need anymore for VC14 ???

Be aware 2.4.42 is around the corner, VC14 is not updated.
Back to top
bagu



Joined: 06 Jan 2011
Posts: 172
Location: France

PostPosted: Thu 19 Mar '20 23:04    Post subject: Reply with quote

VC14 is pretty old now.
I think, it's not a big problem to remove the support.
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 22
Location: Paris, France, EU

PostPosted: Fri 20 Mar '20 10:05    Post subject: Reply with quote

Hi,

I totally agree with Bagu (Hi to you), it is no longer necessary to maintain a VC14 version.
For Wampserver, Apache versions - since 2.4.26 - were only provided with VC15 then VS16.
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 604

PostPosted: Fri 20 Mar '20 11:40    Post subject: Reply with quote

We drop the VC14 builds and move the last VC14 to the Addional download page.

You can upgrade to VS16/VC15 without issues, it is advised. For example if you want to stay on 7.1 and run as module.

See also the post about: Compatibility VS16/VC15/VC14 .

When you are desperate and need some update, please contact me by mail with a good reason.
Back to top


Reply to topic   Topic: Dropping VC14 buids ! View previous topic :: View next topic
Post new topic   Forum Index -> News & Hangout