logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: Apache error.log - want to ensure that everything is fine
Author
EIKA



Joined: 22 Jan 2019
Posts: 29
Location: Russia

PostPosted: Sat 28 Mar '20 20:57    Post subject: Apache error.log - want to ensure that everything is fine Reply with quote

Hi all!

My Apache under Windows works well. I just upgraded to the 2.4.41 from AL downloads section (Win64). But I am just interested what is here can be improved or or may indicate a problem.

This is what I am getting when Apache restart is requested:

Code:
[21:42:34.084041 2020] [mpm_winnt:notice] [pid 4376:tid 336] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[21:42:36.084155 2020] [mpm_winnt:notice] [pid 3780:tid 232] AH00364: Child: All worker threads have exited.
[21:42:36.234164 2020] [mpm_winnt:notice] [pid 4376:tid 336] AH00430: Parent: Child process 3780 exited successfully.
[21:42:38.586298 2020] [:notice] [pid 5012:tid 336] ModSecurity for Apache/2.9.2 (http://www.modsecurity.org/) configured.
[21:42:38.587298 2020] [:notice] [pid 5012:tid 336] ModSecurity: APR compiled version="1.6.2"; loaded version="1.7.0"
[21:42:38.587298 2020] [:warn] [pid 5012:tid 336] ModSecurity: Loaded APR do not match with compiled!
[21:42:38.587298 2020] [:notice] [pid 5012:tid 336] ModSecurity: PCRE compiled version="8.41 "; loaded version="8.43 2019-02-23"
[21:42:38.587298 2020] [:warn] [pid 5012:tid 336] ModSecurity: Loaded PCRE do not match with compiled!
[21:42:38.587298 2020] [:notice] [pid 5012:tid 336] ModSecurity: LUA compiled version="Lua 5.1"
[21:42:38.587298 2020] [:notice] [pid 5012:tid 336] ModSecurity: YAJL compiled version="2.1.0"
[21:42:38.587298 2020] [:notice] [pid 5012:tid 336] ModSecurity: LIBXML compiled version="2.9.4"
[21:42:38.589298 2020] [:notice] [pid 5012:tid 336] ModSecurity: StatusEngine call: "2.9.2,Apache/2.4.41 (Win64) Ope,1.6.2/1.7.0,8.41/8.43 2019-02-23,Lua 5.1,2.9.4,65f95f630f5ad88fd1f990817976146c35130ef4"
[21:42:39.836370 2020] [:notice] [pid 5012:tid 336] ModSecurity: StatusEngine call successfully sent. For more information visit: http://status.modsecurity.org/
[21:42:40.005379 2020] [mpm_winnt:notice] [pid 5012:tid 336] AH00455: Apache/2.4.41 (Win64) OpenSSL/1.1.1e Apache/1.3.42 (Linux 2.4.x) configured -- resuming normal operations
[21:42:40.005379 2020] [mpm_winnt:notice] [pid 5012:tid 336] AH00456: Apache Lounge VS16 Server built: Aug  9 2019 16:46:32
[21:42:40.005379 2020] [core:notice] [pid 5012:tid 336] AH00094: Command line: 'X:\\Apache\\bin\\httpd.exe -d X:/Apache'
[21:42:40.007379 2020] [mpm_winnt:notice] [pid 5012:tid 336] AH00418: Parent: Created child process 1772
[21:42:40.356399 2020] [:notice] [pid 1772:tid 232] ModSecurity for Apache/2.9.2 (http://www.modsecurity.org/) configured.
[21:42:40.357400 2020] [:notice] [pid 1772:tid 232] ModSecurity: APR compiled version="1.6.2"; loaded version="1.7.0"
[21:42:40.357400 2020] [:warn] [pid 1772:tid 232] ModSecurity: Loaded APR do not match with compiled!
[21:42:40.357400 2020] [:notice] [pid 1772:tid 232] ModSecurity: PCRE compiled version="8.41 "; loaded version="8.43 2019-02-23"
[21:42:40.357400 2020] [:warn] [pid 1772:tid 232] ModSecurity: Loaded PCRE do not match with compiled!
[21:42:40.357400 2020] [:notice] [pid 1772:tid 232] ModSecurity: LUA compiled version="Lua 5.1"
[21:42:40.357400 2020] [:notice] [pid 1772:tid 232] ModSecurity: YAJL compiled version="2.1.0"
[21:42:40.357400 2020] [:notice] [pid 1772:tid 232] ModSecurity: LIBXML compiled version="2.9.4"
[21:42:40.393402 2020] [:notice] [pid 1772:tid 232] ModSecurity: StatusEngine call: "2.9.2,Apache/2.4.41 (Win64) Ope,1.6.2/1.7.0,8.41/8.43 2019-02-23,Lua 5.1,2.9.4,65f95f630f5ad88fd1f990817976146c35130ef4"
[21:42:41.545467 2020] [:notice] [pid 1772:tid 232] ModSecurity: StatusEngine call successfully sent. For more information visit: http://status.modsecurity.org/
[21:42:41.718477 2020] [mpm_winnt:notice] [pid 1772:tid 232] AH00354: Child: Starting 64 worker threads.

Also I want to ask, why the most of lines repeats.

As you can see, the same lines are in the first part, and in the second. What is the first part of the log responsible for, and what is the second?

Thanks in advance!
Back to top
EIKA



Joined: 22 Jan 2019
Posts: 29
Location: Russia

PostPosted: Sat 28 Mar '20 21:01    Post subject: Reply with quote

Also I worry a bit about doubled backslashes here:
Code:
X:\\Apache\\bin\\httpd.exe -d X:/Apache'

Is it OK? If YES, why?
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2243
Location: Sun Diego, USA

PostPosted: Sat 28 Mar '20 22:51    Post subject: Reply with quote

Q. why the most of lines repeats.
A. 1 Parent & 1 Child process running, 1 Parent & 1 Child process running being configured.

Q. Is it OK? If YES, why?
A. Yes, it's running and nothing looks out of the ordinary.

However, mod_security could be upgraded to 2.9.3.

There's debate here on whether OpenSSL/1.1.1e is a good move.

Basically you have a choice between a bug (1.1.1e) or a vulnerability (1.1.1d) low priority as it may be.

2.4.43 is releasing probably Sunday or Monday though I know better than to predict it. OpenSSL 1.1.1f should show up later today or tomorrow. You should upgrade the server when it becomes available with 2.4.43/1.1.1f and why not upgrade your mod_security at the same time.
Back to top
EIKA



Joined: 22 Jan 2019
Posts: 29
Location: Russia

PostPosted: Sat 28 Mar '20 23:39    Post subject: Reply with quote

Hi glsmith.

Thank you very much for info. I am not an Apache expert and any input helps a lot.

What it the best way to get updated SSL? Will it be included in Apache 2.4.43 for Windows? Or come as a separate file archive? If separate, where I can get proper archive for Windows x64 and what's the procedure to install updated version of SSL?
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2243
Location: Sun Diego, USA

PostPosted: Sun 29 Mar '20 6:15    Post subject: Reply with quote

If you get Apache 2.4.43 here, it will be included.
Back to top
EIKA



Joined: 22 Jan 2019
Posts: 29
Location: Russia

PostPosted: Sun 29 Mar '20 9:34    Post subject: Reply with quote

Thank you very much. I will wait for the new update version and install ASAP.
Back to top
EIKA



Joined: 22 Jan 2019
Posts: 29
Location: Russia

PostPosted: Tue 31 Mar '20 20:36    Post subject: Reply with quote

Just upgraded to the 2.4.43. Here is new log:
Code:
[21:25:44.559691 2020] [mpm_winnt:notice] [pid 3388:tid 232] AH00364: Child: All worker threads have exited.
[21:25:44.709700 2020] [mpm_winnt:notice] [pid 4144:tid 340] AH00430: Parent: Child process 3388 exited successfully.
[21:26:49.720418 2020] [:notice] [pid 2100:tid 340] ModSecurity for Apache/2.9.3 (http://www.modsecurity.org/) configured.
[21:26:49.720418 2020] [:notice] [pid 2100:tid 340] ModSecurity: APR compiled version="1.7.0"; loaded version="1.7.0"
[21:26:49.720418 2020] [:notice] [pid 2100:tid 340] ModSecurity: PCRE compiled version="8.43 "; loaded version="8.44 2020-02-12"
[21:26:49.720418 2020] [:warn] [pid 2100:tid 340] ModSecurity: Loaded PCRE do not match with compiled!
[21:26:49.720418 2020] [:notice] [pid 2100:tid 340] ModSecurity: LUA compiled version="Lua 5.2"
[21:26:49.720418 2020] [:notice] [pid 2100:tid 340] ModSecurity: YAJL compiled version="2.1.0"
[21:26:49.720418 2020] [:notice] [pid 2100:tid 340] ModSecurity: LIBXML compiled version="2.9.9"
[21:26:49.780422 2020] [:notice] [pid 2100:tid 340] ModSecurity: StatusEngine call: "2.9.3,Apache/2.4.43 (Win64) Ope,1.7.0/1.7.0,8.43/8.44 2020-02-12,Lua 5.2,2.9.9,65..."
[21:26:51.405515 2020] [:notice] [pid 2100:tid 340] ModSecurity: StatusEngine call successfully sent. For more information visit: http://status.modsecurity.org/
[21:26:51.568524 2020] [mpm_winnt:notice] [pid 2100:tid 340] AH00455: Apache/2.4.43 (Win64) OpenSSL/1.1.1f Apache/1.3.42 (Linux 2.4.x) configured -- resuming normal operations
[21:26:51.568524 2020] [mpm_winnt:notice] [pid 2100:tid 340] AH00456: Apache Lounge VS16 Server built: Mar 31 2020 16:01:02
[21:26:51.568524 2020] [core:notice] [pid 2100:tid 340] AH00094: Command line: 'X:\\Apache\\bin\\httpd.exe -d X:/Apache'
[21:26:51.570524 2020] [mpm_winnt:notice] [pid 2100:tid 340] AH00418: Parent: Created child process 4228
[21:26:51.914544 2020] [:notice] [pid 4228:tid 232] ModSecurity for Apache/2.9.3 (http://www.modsecurity.org/) configured.
[21:26:51.914544 2020] [:notice] [pid 4228:tid 232] ModSecurity: APR compiled version="1.7.0"; loaded version="1.7.0"
[21:26:51.914544 2020] [:notice] [pid 4228:tid 232] ModSecurity: PCRE compiled version="8.43 "; loaded version="8.44 2020-02-12"
[21:26:51.914544 2020] [:warn] [pid 4228:tid 232] ModSecurity: Loaded PCRE do not match with compiled!
[21:26:51.914544 2020] [:notice] [pid 4228:tid 232] ModSecurity: LUA compiled version="Lua 5.2"
[21:26:51.914544 2020] [:notice] [pid 4228:tid 232] ModSecurity: YAJL compiled version="2.1.0"
[21:26:51.915544 2020] [:notice] [pid 4228:tid 232] ModSecurity: LIBXML compiled version="2.9.9"
[21:26:51.930545 2020] [:notice] [pid 4228:tid 232] ModSecurity: StatusEngine call: "2.9.3,Apache/2.4.43 (Win64) Ope,1.7.0/1.7.0,8.43/8.44 2020-02-12,Lua 5.2,2.9.9,65..."
[21:26:53.413629 2020] [:notice] [pid 4228:tid 232] ModSecurity: StatusEngine call successfully sent. For more information visit: http://status.modsecurity.org/
[21:26:53.597640 2020] [mpm_winnt:notice] [pid 4228:tid 232] AH00354: Child: Starting 64 worker threads.

The only mismatch is PCRE version. Shall I fix it?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2827
Location: Hilversum, NL, EU

PostPosted: Tue 31 Mar '20 21:00    Post subject: Reply with quote

No all fine mod_security is now using pcre 8.44.
Back to top
EIKA



Joined: 22 Jan 2019
Posts: 29
Location: Russia

PostPosted: Tue 31 Mar '20 21:02    Post subject: Reply with quote

Thanks for all of your help and work. Really appreciate.
Back to top


Reply to topic   Topic: Apache error.log - want to ensure that everything is fine View previous topic :: View next topic
Post new topic   Forum Index -> Apache