logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: PHP 7.4.8, 7.3.20, 7.2.32, 7.1, 7.0, 5.6, 5.5, 5.4, 5.3 Page Previous  1, 2, 3 ... , 12, 13, 14  Next
Author
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Fri 24 Apr '20 15:09    Post subject: Reply with quote

I am linking libssh2 1.9.0 statically so there is no external libssh2.dll needed.

See https://windows.php.net/downloads/php-sdk/deps/vc15/x64/libssh2-1.9.0-vc15-x64.zip

If you link the libssh2_a.lib in stead of the libssh2.lib all ssh2 code is included.
Back to top
ltdeta



Joined: 27 Feb 2015
Posts: 3
Location: Germany

PostPosted: Fri 24 Apr '20 15:36    Post subject: Reply with quote

Wow, many thanks for the quick answer!

Can you please tell me how I can get the right runtime dlls for ImageMagick?

I have the current version from here https://mlocati.github.io/articles/php-windows-imagick.html
php_imagick-3.4.4-7.2-ts-vc15-x86.zip / ImageMagick-7.0.7-11-vc15-x86.zip

But what I really miss are the dll's you're using
Unfortunately I do not understand how I can get the right Dll's with the following information.
Quote:
The dependencies for php_imagick.dll can be found as artifact on
https://ci.appveyor.com/project/Jan-E/imagemagick-windows/builds/31561250
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Fri 24 Apr '20 16:15    Post subject: Reply with quote

My builds contain a php_imagick.dll with version ImageMagick 7.0.10-1 Q16 x86

Then the DLL's are here:
https://ci.appveyor.com/project/Jan-E/imagemagick-windows/builds/31561250/job/jprkxomn0fhkwgo4/artifacts

In the zip file.

But mlocati provides the DLL's for the PHP.net builds as well. Click in the right column and you will find http://windows.php.net/downloads/pecl/deps/ImageMagick-7.0.7-11-vc15-x86.zip
Back to top
ltdeta



Joined: 27 Feb 2015
Posts: 3
Location: Germany

PostPosted: Sat 25 Apr '20 22:01    Post subject: Reply with quote

thanks, now all works perfekt!
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 43
Location: Flower Mound, TX

PostPosted: Wed 29 Apr '20 16:28    Post subject: Image Magick not working Reply with quote

I seriously doubt anyone here can help me. We are using Server 2008 R2 IIS servers (yes, I know, and we are working to replace these as fast as we can, but lack resources). Up until 7.4 (Image Magick 6), we were able to get this working, but I've tried everything with this current version and no matter what I do, I get this:

RegistryKeyLookupFailed `CoderModulesPath' @ error/module.c/GetMagickModulePath/665

Works on my machine (Windows 10, Apache), and nothing has changed with the configuration, just updated PHP and Image Magick files.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Wed 29 Apr '20 16:31    Post subject: Reply with quote

Are you using Imagick 6 or 7? Let me try on my 2008 R2 (with Apache, not IIS).
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 43
Location: Flower Mound, TX

PostPosted: Wed 29 Apr '20 16:45    Post subject: Reply with quote

Jan-E wrote:
Are you using Imagick 6 or 7? Let me try on my 2008 R2 (with Apache, not IIS).


Image Magick 7. I've tried both the artifact from your AppVeyor instance and the one that mlocati references. Both work on my machine, but neither work on the production servers.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Wed 29 Apr '20 16:52    Post subject: Reply with quote

I know you do not want it, but did you also try to run the installer (in my artifacts)? There is a chance that it writes things to the register.
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 43
Location: Flower Mound, TX

PostPosted: Wed 29 Apr '20 17:53    Post subject: Reply with quote

Jan-E wrote:
I know you do not want it, but did you also try to run the installer (in my artifacts)? There is a chance that it writes things to the register.


So you were right for me to try that. After some testing, the registry entries are required. However, I don't know why that is with this version, we have gotten by with just putting c:\imagemagick in the path up until now. I know what these registry entries are for - we've been down this road with IM and this particular error MANY times (too many) and finally had it all working by just putting all the /bin files in c:\imagemagick and then adding that to the path. That is the way I have it on my Windows 10 machine and it works just fine. So, I'm totally confused, but nonetheless, if it's working I can probably figure out what I need to do it keep this going until we can replace these servers with Linux + Apache (or possibly a newer Windows Server + Apache if we can't make the full leap first).
Back to top
tanquang



Joined: 21 Mar 2020
Posts: 13
Location: Vietnam

PostPosted: Fri 08 May '20 12:11    Post subject: Re: PHP 7.4.5, 7.3.17, 7.2.30, 7.1.33, 7.0, 5.6, 5.5, 5.4, 5 Reply with quote

I have a problem with PHP 5.3.29 and 5.4.45 TS (x64) unable to start because libssh2.dll was not found.
----- UPDATE -----
I copied php_ssh2.dll from the ext directory to the root directory and changed the name to libssh2.dll.
Thank a lot.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Fri 08 May '20 12:41    Post subject: Reply with quote

The extension name is php_ssh2.dll. It should be loaded with extension_dir pointing to the full path of the ext directory and extension=php_ssh2.dll.

php_ssh2.dll is only dependent on the OpenSSL DLL's. See snapshot.txt in the zips. My x64 builds of PHP 5.3 and 5.4 do not require a separate libssh2.dll.

If you get a message that libssh2.dll is missing, it must be another program that is complaining about it.
Back to top
tanquang



Joined: 21 Mar 2020
Posts: 13
Location: Vietnam

PostPosted: Sat 09 May '20 2:42    Post subject: Reply with quote

Jan-E wrote:
The extension name is php_ssh2.dll. It should be loaded with extension_dir pointing to the full path of the ext directory and extension=php_ssh2.dll.

php_ssh2.dll is only dependent on the OpenSSL DLL's. See snapshot.txt in the zips. My x64 builds of PHP 5.3 and 5.4 do not require a separate libssh2.dll.

If you get a message that libssh2.dll is missing, it must be another program that is complaining about it.

I tried compiling PHP 5.3.29 and 5.4.45 x86_64 like the x86 release version on windows.php.net from the source code of PHP.
However, I always get compilation errors like when I run "nmake snap", I get the error "NMAKE: fatal error U1077: return code '0x2'",...
If possible, could you guide me?
I just want to compile the x86_64 version just like its x86 release (with DLLs, EXEs running on x64), doesn't need all the exts as yours.
Also, I have problems with your PHP versions 5.3.29 and 5.4.45, when I run php.exe, I get the error: "PHP Warning: PHP Startup: Unable to load dynamic library 'D:\php\php-5
.4.45\ext\php_xsl.dll' - The application has failed to start because its side-by
-side configuration is incorrect. Please see the application event log or use th
e command-line sxstrace.exe tool for more detail.
in Unknown on line 0"
Can you fix it?
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Sat 09 May '20 8:09    Post subject: Reply with quote

The only way to compile this yourself is to install the "Microsoft Visual Studio 2008 Beta2 x64 tools", which provide a X64 version of the V90 dll's for VC9.

For compiling some dependencies (like SSH2) you will also need the same X64 "Visual Studio 2008 (v90)" platform toolset in Visual Studio 2012.

If you cannot figure out how to install the X64 VC9 toolset I cannot help you. I installed this a long, long time ago and could not even migrate them from Windows 7 to Windows 10. So for compiling the X64 versions of PHP 5.3 and PHP 5.4, I am still booting my laptop under Windows 7 Pro.

I do not know why php_xsl.dll is giving the side-by-side error. php_curl.dll for instance relies on the same external DLL's (x64 versions of KERNEL32.dll, ADVAPI32.dll and MSVCR90.dll) and even a lot more. If php_curl.dll loads and php_xsl.dll does not, I am at a loss.

The only advice might be to install the VC9 X64 redistributable: https://www.microsoft.com/en-us/download/details.aspx?id=15336
Back to top
tanquang



Joined: 21 Mar 2020
Posts: 13
Location: Vietnam

PostPosted: Sat 09 May '20 12:00    Post subject: Reply with quote

What is your configuration? I use this configuration (I took it from phpinfo() of PHP 5.3 and 5.4 for the x86 release) and when the compilation got an error even though I installed Visual C++ 9 (both x86 and x64).
Code:
configure --enable-snapshot-build --disable-isapi --enable-debug-pack --without-mssql --without-pdo-mssql --without-pi3web --with-pdo-oci=C:\php-sdk\oracle\instantclient10\sdk,shared --with-oci8=C:\php-sdk\oracle\instantclient10\sdk,shared --with-oci8-11g=C:\php-sdk\oracle\instantclient11\sdk,shared --enable-object-out-dir=../obj/ --enable-com-dotnet=shared --with-mcrypt=static --disable-static-analyze
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Sat 09 May '20 12:19    Post subject: Reply with quote

See the phpinfo.htm inside the zips. It is really a long one.
But this will not work for a X64 build if you cannot open a X64 command prompt in VS2008, which is
Quote:
Setting environment for using Microsoft Visual Studio 2008 Beta2 x64 tools.
Back to top
tanquang



Joined: 21 Mar 2020
Posts: 13
Location: Vietnam

PostPosted: Sat 09 May '20 17:03    Post subject: Reply with quote

I tried both of them, but I got an error when I compiled.

https://i.imgur.com/ZlR99tu.png

I just want to compile the x64 release version like in the image (only include files and ext like the x86 release).

https://i.imgur.com/TUH7KLz.png

https://i.imgur.com/77NiAae.png
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Sat 09 May '20 18:53    Post subject: Reply with quote

I usually take the pure Win64 command prompt, not the Cross compiler. But both should work.

The error is probably caused by your dependencies not being X64, but X86. For enchant there is a Winlibs VC11 project:
https://github.com/winlibs/enchant/tree/master/msvc11

Open that one in Visual Studio 2012, change the toolset to V90 and X64 and try to get it building.

Or load the original VS2008 project file in https://github.com/winlibs/enchant/tree/29fc9a209d41680feb8e7ab0496e48fca98da027/msvc change it to X64 and try to get that one building.

Tip: do not put your dependencies in a 'deps' dir. If there is no deps-dir the configure of PHP will look for a 'win32build' dir for X86 and for a 'win64build' dir for X64. If you have a deps dir for the X86 build rename it to win32build.

All your dll's and libs in win64build\bin, win64build\lib and win64build\template\dlls should be X64. The includes in win64build\include can be the same for X64 as for X86.

BTW: remove the oci-related options in your original configure line unless you really want to build php_oci8.dll and php_pdo_oci.dll.
Back to top
tanquang



Joined: 21 Mar 2020
Posts: 13
Location: Vietnam

PostPosted: Sat 09 May '20 19:19    Post subject: Reply with quote

I will install VS 2012 Ultimate, I still don't understand how to build PHP with it, can you give more detailed instructions?
I don't use php_oci8.dll and php_pdo_oci.dll, I compile it just to give "enough" and like the release (especially avoid later errors).
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1039
Location: Amsterdam, NL, EU

PostPosted: Sat 09 May '20 19:27    Post subject: Reply with quote

VS2012 is just for building X64 dependencies when you do not have a VC9 project to build those dependencies. For instance, my libssh2_a.lib for PHP 5.3/5.4 X64 was built in a VS2012 X64 project with platform toolset V90.

Building PHP 5.3/5.4 itself is done in a VS2008 X64 command prompt with configure and nmake snap.

Building the oci extensions will not work at all with your original configure line, because the dll's and libs in C:\php-sdk\oracle\instantclient11\sdk are X86. Do not use any X86 dll or lib when building X64. All will fail.
Back to top
tanquang



Joined: 21 Mar 2020
Posts: 13
Location: Vietnam

PostPosted: Sat 09 May '20 19:58    Post subject: Reply with quote

I wrote an article on the problem I built PHP 5.3.29 and 5.4.45 encountered an error. Can you read it and give me a solution?
Link here: https://serverfault.com/questions/1016395/how-to-compile-php-5-3-and-php-5-4-release-x64-with-visual-studio-2008-sp1
The instantclient files that I use are all x64.
I have installed Visual Studio 2012, I don't know what to do next?
Back to top


Reply to topic   Topic: PHP 7.4.8, 7.3.20, 7.2.32, 7.1, 7.0, 5.6, 5.5, 5.4, 5.3 View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads Page Previous  1, 2, 3 ... , 12, 13, 14  Next