logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: Apache 2.4.46 - Modules directory path change?
Author
Joey



Joined: 27 Oct 2020
Posts: 2
Location: Czech Republic

PostPosted: Tue 27 Oct '20 14:50    Post subject: Apache 2.4.46 - Modules directory path change? Reply with quote

Hello Colleagues,\

I'm using ~Eclipse IDE for Enterprise Java Developers Version: 2020-03 (4.15.0) to build Apache 2.4.46 packages.
with

pcre 8.44
expat 2.2.9
openssl 1.1.107
lua 5.4.0
apr 1.7.0
apr-util 1.6.1
apr-iconv 1.2.2
ldap 2.4.53

During Installation, I see directories being created, and libtool installs the modules in /applications/apache/2.4.46.0/usr/lib/httpd/modules.
I'd like the path to the modules to be in /applications/apache/2.4.46.0/modules.
Is there a way to tell libtool to use /applications/apache/2.4.46.0/modules ??

FYI: I already have Apache configure run with:
# Configure Apache
./configure \
--prefix=$PREFIX \
--with-ssl=${PREFIX_SSL} \
--enable-layout=BLFS \
--enable-mods-shared="all cgi" \
--enable-mpms-shared=all \
--with-apr=${PREFIX}/bin/apr-1-config\
--with-apr-util=${PREFIX}/bin/apu-1-config\
--with-expat=${PREFIX_EXPAT} \
--with-lua=${PREFIX_LUA} \
--enable-static-support \
--enable-suexec\
--enable-cgi\
--with-suexec\
--with-pcre=${PREFIX_PCRE}/bin/pcre-config\
--enable-mpms-shared=all \
--enable-mods-shared=reallyall\
--enable-foo\

where PREFIX=/applications/apache/2.4.46.0
---------------------------------------------------------------------------------
# FROM BUILDLOG
.....
make[4]: Entering directory `/tmp/build_apache_24/httpd-2.4.46/server/mpm/event'
mkdir /applications/apache/2.4.46.0/usr
mkdir /applications/apache/2.4.46.0/usr/lib
mkdir /applications/apache/2.4.46.0/usr/lib/httpd
mkdir /applications/apache/2.4.46.0/usr/lib/httpd/modules
.....
make[2]: Entering directory `/tmp/build_apache_24/httpd-2.4.46/modules/aaa'
make[3]: Entering directory `/tmp/build_apache_24/httpd-2.4.46/modules/aaa'
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authn_file.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authn_dbm.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authn_anon.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authn_dbd.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authn_socache.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authn_core.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authz_host.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authz_groupfile.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authz_user.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authz_dbm.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authz_owner.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authz_dbd.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authz_core.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_authnz_fcgi.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_access_compat.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_auth_basic.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_auth_form.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_auth_digest.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
/applications/apache/2.4.46.0/build-1/libtool --silent --mode=install install mod_allowmethods.la /applications/apache/2.4.46.0/usr/lib/httpd/modules/
make[3]: Leaving directory `/tmp/build_apache_24/httpd-2.4.46/modules/aaa'
make[2]: Leaving directory `/tmp/build_apache_24/httpd-2.4.46/modules/aaa'
...

I appreciate your feedback
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6859
Location: Germany, Next to Hamburg

PostPosted: Tue 27 Oct '20 16:45    Post subject: Reply with quote

It seems that you don't override that correctly, since ./configure --prefix= does the job correctly (usually).

I I do a pure command line build see https://github.com/JBlond/debian_build_apache24/blob/master/build_apache.sh
Back to top
tangent



Joined: 16 Aug 2020
Posts: 19
Location: UK

PostPosted: Wed 28 Oct '20 0:52    Post subject: Reply with quote

As James says, it looks like --prefix is being ignored.

Your reference to PREFIX is $PREFIX rather than ${PREFIX}, and whilst the curly brackets shouldn't make any difference shell wise, your other variable references do. Maybe the configure script is fussy?
Back to top
Joey



Joined: 27 Oct 2020
Posts: 2
Location: Czech Republic

PostPosted: Wed 28 Oct '20 12:17    Post subject: Apache 2.4.46 - Modules directory path change? Reply with quote

Thanks for the feedback @Tangent & @James

I tried to edit the reference to PREFIX from $PREFIX to ${PREFIX} and still the same - no change.
Even hard coding it as /applications/apache/2.4.46.0 still does not change anything.
"/usr/lib/httpd " is still being appended to ${prefix}

/applications/apache/2.4.46.0/usr/lib/httpd/modules/...

Any suggestion(s)?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6859
Location: Germany, Next to Hamburg

PostPosted: Wed 28 Oct '20 13:12    Post subject: Reply with quote

Maybe the path to /usr/.... is somewhere in your IDE? Did you try a complete command line build?
Back to top


Reply to topic   Topic: Apache 2.4.46 - Modules directory path change? View previous topic :: View next topic
Post new topic   Forum Index -> Apache