logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: How to disable: http://mysite.loc:8888 > mysite.loc:8888
Author
iwpress



Joined: 29 May 2021
Posts: 4
Location: Poland, Krakow

PostPosted: Sat 29 May '21 19:32    Post subject: How to disable: http://mysite.loc:8888 > mysite.loc:8888 Reply with quote

Hello everyone!
Sorry for the stupid question, maybe this has already been discussed. I am a navichok and I will not be able to re-read all the posts. Help me understand!

After my intervention in the local Apache (macOS) settings (tried to change port 8888 to 80), my WordPress site stopped working.
Everywhere I have http://iwp2.loc:8888 is converted to iwp2.loc:8888 and as a result, all transitions on internal links, for example:
http://iwp2.loc:8888/about/ is converted to iwp2.loc:8888/about/ and give 404 error (Not Found. The requested URL was not found on this server).
What leads to this transformation?

Tried:
1. Removed .htaccess
2. Disable mod_alias.so in httpd.conf.
Does not help.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6981
Location: Germany, Next to Hamburg

PostPosted: Wed 02 Jun '21 16:57    Post subject: Reply with quote

That is the stored in the Database from Wordpress. You need to change that in the Database itself or the backend, if you are still able to login.
Back to top
iwpress



Joined: 29 May 2021
Posts: 4
Location: Poland, Krakow

PostPosted: Wed 02 Jun '21 23:07    Post subject: Reply with quote

James Blond wrote:
That is the stored in the Database from Wordpress. You need to change that in the Database itself or the backend, if you are still able to login.


Thanks James Blond!

You're right. I have already restored the server and site to work. my WordPress site works as before. And now I'm thinking that transformation http: //iwp2.loc: 8888 in iwp2.loc: 8888 doesn't interfere with my internal links. Yes, during my experiments the WordPress database was changed. Now I got it right.

Sorry for the stupid question. I was confused by the other behavior of the site on external hosting.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6981
Location: Germany, Next to Hamburg

PostPosted: Thu 03 Jun '21 15:39    Post subject: Reply with quote

if you still have a question please ask again!
Back to top
iwpress



Joined: 29 May 2021
Posts: 4
Location: Poland, Krakow

PostPosted: Thu 03 Jun '21 20:46    Post subject: Reply with quote

James Blond wrote:
if you still have a question please ask again!


Thank you! Not now.
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 40
Location: Paris, France, EU

PostPosted: Sat 05 Jun '21 9:09    Post subject: Re: How to disable: http://mysite.loc:8888 > mysite.loc:8 Reply with quote

iwpress wrote:
Everywhere I have http://iwp2.loc:8888 is converted to iwp2.loc:8888

Hi,

It may be a browser setting that does not show the http:// or https:// protocol in the urls.

This exists by default with the last versions of Firefox and I disabled it to really know if I am in https or not.

For example, in Firefox, it is in about:config
browser.urlbar.trimURLs false
Back to top
iwpress



Joined: 29 May 2021
Posts: 4
Location: Poland, Krakow

PostPosted: Sat 05 Jun '21 11:28    Post subject: Re: How to disable: http://mysite.loc:8888 > mysite.loc:8 Reply with quote

Otomatic wrote:
iwpress wrote:
Everywhere I have http://iwp2.loc:8888 is converted to iwp2.loc:8888

Hi,

It may be a browser setting that does not show the http:// or https:// protocol in the urls.

This exists by default with the last versions of Firefox and I disabled it to really know if I am in https or not.

For example, in Firefox, it is in about:config
browser.urlbar.trimURLs false


Hi,
Thanks for the answer.

I have Safari and have "Show full website url" checked in the settings. However, an address without http:// is displayed.
But this did not interfere with the site's work. As a result of inaccurate changes, my WordPress database has changed. As soon as I fixed everything, the site worked as before.
Back to top


Reply to topic   Topic: How to disable: http://mysite.loc:8888 > mysite.loc:8888 View previous topic :: View next topic
Post new topic   Forum Index -> Apache