logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.


Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: Lua 5.4.2 compilation error with Apache 2.4.51
Author
Anitha



Joined: 25 Sep 2016
Posts: 32
Location: india

PostPosted: Sat 20 Nov '21 21:52    Post subject: Lua 5.4.2 compilation error with Apache 2.4.51 Reply with quote

Hi Team,
I am using Apache version 2.4.51 and compiler using cmake on(vc++14) on windows.

And i used the following command for compilation. Kindly help.

cmake -G "NMake Makefiles" -DCMAKE_INSTALL_PREFIX=D:\Apache24\ -DCMAKE_BUILD_TYPE=Release
nmake
nmake install

Error :

CMake Warning:
No source or binary directory provided. Both will be assumed to be the
same as the current working directory, but note that this warning will
become a fatal error in future CMake releases.


CMake Error: The source directory "C:/httpd-2.4.51/srclib/lua" does not appear t
o contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.


Thanks,
Anitha.S
Back to top
tangent



Joined: 16 Aug 2020
Posts: 150
Location: UK

PostPosted: Sat 20 Nov '21 23:02    Post subject: Reply with quote

The LUA project does not currently support CMake; hence the lack of a CMakeLists.txt file, though there are several forks on GitHub which do.

The Apache CMake build process detailed here (https://www.apachelounge.com/viewtopic.php?p=39754) does support LUA 5.4. Check out the "additional notes" section, which references an additional CMakeLists.txt file, viz:
This may help with your build process.
Back to top
Anitha



Joined: 25 Sep 2016
Posts: 32
Location: india

PostPosted: Sun 21 Nov '21 19:45    Post subject: Reply with quote

Thanks a lot for the immediate reply Smile Smile.
Back to top


Reply to topic   Topic: Lua 5.4.2 compilation error with Apache 2.4.51 View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads