logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS Twitter


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: PHP 5.3.10 & Xdebug unable to work[fixed]
Author
Ray



Joined: 11 Nov 2022
Posts: 1
Location: Taiwan

PostPosted: Mon 14 Nov '22 5:08    Post subject: PHP 5.3.10 & Xdebug unable to work[fixed] Reply with quote

I need a little help, I need to maintain a php documents which use old version to work on. The project use PHP Version 5.5.38.

PHP 5.5.38 ini-> Compiler MSVC11 Architecture x86 Zend Extension Build API220121212,TS,VC11 PHP Extension Build API20121212,TS,VC11

I need to use Xdebug for tracing. But the version before PHP 7 is not supported by wizard. I download Xdebug 2.2.7 -> PHP 5.5 VC11 (32 bit) and PHP 5.5 VC11 TS (32 bit), but both of them are not working.

1.I need to know if I'm using a debug file that doesn't match my PHP version.

2.I have tested many sets of [xdebug] code in php.ini , but since I did not work successfully, I don't know which set of [xdebug] code is correct in version 5.5.38, how do I find the correct 5.5.38 version code.

I have tried this

Code:
[xdebug]
zend_extension = "D:\xampp\php\ext\php_xdebug-3.1.2-7.4-vc15-x86_64.dll"
xdebug.mode = debug
xdebug.start_with_request = yes
xdebug.remote_enable = 1
xdebug.remote_autostart = 1


or something like this

Code:
[xdebug]
zend_extension = "D:\xampp\php\ext\php_xdebug-3.1.2-7.4-vc15-x86_64.dll"
xdebug.remote_enable=1
xdebug.remote_connect_back=On
xdebug.remote_port="9000"
xdebug.profiler_enable=0
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_autostart=true


Update:
Thank you for the reply from the enthusiastic PHP version friends, I have obtained the reference answer to solve my problem in this page.
https://stackoverflow.com/questions/73317925/how-to-debug-project-with-php-5-6-in-visual-studio-code


Last edited by Ray on Mon 14 Nov '22 11:24; edited 1 time in total
Back to top
Otomatic



Joined: 01 Sep 2011
Posts: 93
Location: Paris, France, EU

PostPosted: Mon 14 Nov '22 9:58    Post subject: Reply with quote

Hi,

PHP 5.5.38 32 or 64 bit must use xDebug 2.4.0 VC11.
Code:

; XDEBUG Extension
[xdebug]
zend_extension ="c:/wamp/bin/php/php5.5.38/zend_ext/php_xdebug-2.4.0-5.5-vc11.dll"
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir ="c:/wamp/tmp"
xdebug.show_local_vars=0

I would like to point out that PHP 5.5.38 can still be installed on Wampserver 3.2.9 and works without any problem both in Apache module mode and in FCGI mode.

The latest xDebug version supported by PHP 5.5 is 2.5.5
Back to top


Reply to topic   Topic: PHP 5.3.10 & Xdebug unable to work[fixed] View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads