logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS X


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> News & Hangout View previous topic :: View next topic
Reply to topic   Topic: Dropped VS16 downloads
Author
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 3046
Location: Hilversum, NL, EU

PostPosted: Wed 31 May '23 10:01    Post subject: Dropped VS16 downloads Reply with quote

We dropped the VS16 builds and moved the last VS16 to the Additonal download page.

you can upgrade to VS17, all VS16 binaries and modules are compatible with VS17.

Note PHP and OpenSSL. VS17 is build with latest OpenSSL 3.x.x. Only PHP 8.2 and 8.1 (build with 3.x.x) is running as module.
It is strongly advised to run e.g. PHP with mod_fcgid, then you can run any and/or more PHP versions.

See also the discussion at : https://www.apachelounge.com/viewtopic.php?t=9057
Back to top
megamurmulis



Joined: 31 May 2023
Posts: 1
Location: Latvia

PostPosted: Wed 31 May '23 18:27    Post subject: Re: Dropped VS16 downloads Reply with quote

I have been using both Apache VS16 and VC17 binaries - with PHP (5.6, 7.4, 8.0, 8.1, 8.2) as php module = but did not notice any issues..
(SSL cert loads ok, ssl stream access works fine too)


~ In what way is the problem observable for older PHP versions?
(and PHP 8.1 seems to be linked with openSSL v1.1.1 not v3)


---
I am using the following for loading as module based on param:
Code:
<IfDefine php_56>
   PHPIniDir "F:/WEB/php_56"
   LoadModule php5_module "F:/WEB/php_56/php5apache2_4.dll"
</IfDefine>
<IfDefine php_74>
   PHPIniDir "F:/WEB/php_74"
   LoadModule php7_module "F:/WEB/php_74/php7apache2_4.dll"
</IfDefine>
<IfDefine php_80>
   PHPIniDir "F:/WEB/php_80"
   LoadModule php_module "F:/WEB/php_80/php8apache2_4.dll"
</IfDefine>
<IfDefine php_81>
   PHPIniDir "F:/WEB/php_81"
   LoadModule php_module "F:/WEB/php_81/php8apache2_4.dll"
</IfDefine>
<IfDefine php_82>
   PHPIniDir "F:/WEB/php_82"
   LoadModule php_module "F:/WEB/php_82/php8apache2_4.dll"
</IfDefine>
<IfDefine !xphp>
   PHPIniDir "F:/WEB/php_74"
   LoadModule php7_module "F:/WEB/php_74/php7apache2_4.dll"
</IfDefine>

<FilesMatch "\.ph(p[2-6]?|tml)$">
   SetHandler application/x-httpd-php
</FilesMatch>


And run specific php version by batch:
Code:
SET _php_ver=82
title Apache24 + php_%_php_ver%
SET PATH=%PATH%;F:\WEB\php_%_php_ver%;F:\WEB\Apache24\bin
"F:\WEB\Apache24\bin\httpd.exe" -w -X -Dxphp -Dphp_%_php_ver%
Back to top


Reply to topic   Topic: Dropped VS16 downloads View previous topic :: View next topic
Post new topic   Forum Index -> News & Hangout