logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in  RSS Apache Lounge  


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.



Post new topic   Forum Index -> Apache View previous topic :: View next topic
Reply to topic   Topic: windows (os)warn
Author
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Wed 20 Dec '06 20:28    Post subject: windows (os)warn Reply with quote

Hi I have been getting os warning,s when accessing from a computer out side
my local the warning are in the error logs
(os 121)The semaphore time out period has expired :wint_accept: asynchronous AcceptEx failed
(os64)the specified network is no longer available :wint_accept:asynchronous
AcceptEx failed
I have tried disabling acceptEx after doing this the network was lost completely and I had to unintsall and install the apache again to get the network back but still get the os warning,s what should I try next to solve this problem
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6785
Location: Germany, Next to Hamburg

PostPosted: Thu 21 Dec '06 10:16    Post subject: Reply with quote

Add this to your httpd.conf

Code:

EnableMMAP off
EnableSendfile off
Win32DisableAcceptEx


Please do not crosspost!
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Wed 27 Dec '06 4:53    Post subject: Reply with quote

After disabling AcceptEx I am getting a error mes. in my windows logs in the application logs event 3299 is this normal or has the disabling not worked out right it says disabled when I start the apache as notice in the apache error logs I have looked for more info. on event 3299 but could fined nothing more
than it refers to AcceptEx being disabled
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6785
Location: Germany, Next to Hamburg

PostPosted: Wed 27 Dec '06 11:06    Post subject: Reply with quote

I googled a bit for event ID 3299. Seems that a modul could not be load. Can you copy the full error message? That would help to solve it.

If realy al setups fail, please follow this setup

http://www.apachelounge.com/viewtopic.php?t=570
Read all post in that topic Wink
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Wed 27 Dec '06 12:20    Post subject: Reply with quote

error date time Apache service event 3299
The Apache service named reported the following error disabled use of AcceptEx() Winsock 2 API this is in the windows event viewer

It says the same in the apache error logs when starting as a notice
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6785
Location: Germany, Next to Hamburg

PostPosted: Wed 27 Dec '06 13:22    Post subject: Reply with quote

stop your service and start apache from the console

Code:

httpd -e debug -t


What does it output?
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Wed 27 Dec '06 15:42    Post subject: Reply with quote

from the Apache wintty console pipe commands dont work not the -k start
not httpd -e debug -t or all combinations did not work worked it only will start from apache monitor or the apache icon I have express C++ can it be debug with that if so how to do that
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Wed 27 Dec '06 16:54    Post subject: Reply with quote

I have attached the express C++ debug to the apache exe will that do for debugging and do I have to leave the express studio running for the debug to keep debugging or will it keep debugging after exiting the studio
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6785
Location: Germany, Next to Hamburg

PostPosted: Wed 27 Dec '06 18:33    Post subject: Reply with quote

Where did you download your apache or did you compile it yourself?
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Wed 27 Dec '06 18:44    Post subject: Reply with quote

apache.org mis installer windows xp home with visual studio package but the debug from it did not pan out it keeps saying no symbols loaded and that there is no debugging info. yet the apache works good on my local LaughingI have Zone Alarm fire wall with bug and virus sifting witch is most likely affecting the acceptEx have been trying to get public access for some time now but still have not got the bugs worked out of it but I shall keep trying untill I get it all working dont matter how long it takes
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6785
Location: Germany, Next to Hamburg

PostPosted: Wed 27 Dec '06 19:05    Post subject: Reply with quote

Turn off all firewalls also windows firewall and try again. Many firewalls blocks apache. Wink
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Wed 27 Dec '06 20:21    Post subject: Reply with quote

Have there been problems with the windows sp2 fire wall as I dont want leave Both fire walls of for long time and dont have a second terminal to run the test untill my brother is av.I have switched to that and turned of Zone Alarm to see what happens should I remove the disable acceptEx and use acceptEx with window sp2 fire wall
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Fri 29 Dec '06 4:20    Post subject: Reply with quote

Hi if I wanted to fined the winnt-accept module or config files where mite I look for it I can only find mpm file but not the winnt_accept or AcceptEx
accept in the mpm file Embarassed
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6785
Location: Germany, Next to Hamburg

PostPosted: Fri 29 Dec '06 11:39    Post subject: Reply with quote

The clue is that there is no winnt_accect or AcceptEx in any config file over the world Wink It is compiled into apache. See in the offical docs for that

http://httpd.apache.org/docs/2.2/mod/mpm_winnt.html

If we shall help you, please follow the instructions.


put again this into httpd.conf

EnableMMAP off
EnableSendfile off
Win32DisableAcceptEx


start apache with

httpd -e debug -t

and post the output from that.


or start over with

http://www.apachelounge.com/viewtopic.php?t=570
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Fri 29 Dec '06 18:18    Post subject: Reply with quote

Yes thank you have read all of that page and links it seems that when I use the Win32DisableAcceptEx the network seems to vanish like it is not there.next I am using AMD XP for xp windows only is that why non of the command line,s will not accept apache commands not from the apache command line not for windows command promt switched to the apache bin nun of the apache commands work there as well even wen follow the directions to the letter as I want to use the zip apache but cant with out the command line working :oops:get mes. this is not an integral or external command nor batch or exe file for all commands from
C:\Program Files\Apache Software Foundation\apache2.2\bin>
commands used
apache -k start
-k start
apache -k shutdown and so so forth Confused
same for the apache lounge zip that you seg. from your kink
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Sat 30 Dec '06 8:53    Post subject: Reply with quote

Setting environment for using Microsoft Visual Studio 2005 x86 tools.

C:\Program Files\Microsoft Visual Studio 8\VC>cd "\Program Files\Apache Software
Foundation\Apache2.2\bin"

C:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd.exe -k stop
[Fri Dec 29 22:40:29 2006] [error] (OS 2)The system cannot find the file specifi
ed. : No installed service named "Apache2".

C:\Program Files\Apache Software Foundation\Apache2.2\bin>http.exe
'http.exe' is not recognized as an internal or external command,
operable program or batch file.

C:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd.exe
[Fri Dec 29 22:42:36 2006] [notice] Disabled use of AcceptEx() WinSock2 API
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

C:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd.exe
[Fri Dec 29 22:47:14 2006] [notice] Disabled use of AcceptEx() WinSock2 API
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

can this Info help solve the lost network when using Win32DisableAcceptEx
ps disregard last post I found out how to make command promt work with apache Embarassed
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6785
Location: Germany, Next to Hamburg

PostPosted: Sat 30 Dec '06 10:41    Post subject: Reply with quote

Bruce wrote:
Setting environment for using Microsoft Visual Studio 2005 x86 tools.

C:\Program Files\Microsoft Visual Studio 8\VC>cd "\Program Files\Apache Software
Foundation\Apache2.2\bin"

C:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd.exe -k stop
[Fri Dec 29 22:40:29 2006] [error] (OS 2)The system cannot find the file specifi
ed. : No installed service named "Apache2".


Ok, that show that you have not installed Apache as service. But that is ok.

Quote:

C:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd.exe
[Fri Dec 29 22:42:36 2006] [notice] Disabled use of AcceptEx() WinSock2 API
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


make_sock: could not bind to address 0.0.0.0:80
Means that there is another programm listen on Port 80 or blocked by a firewall.
Do you run skype? Skype uses port 80. So if ye, stop skype.
Turn off any firewalls.
Back to top
Bruce



Joined: 28 Nov 2006
Posts: 77
Location: Mars

PostPosted: Sat 30 Dec '06 14:54    Post subject: Reply with quote

could it bee blocked by my isp adsl server what would be your suggestion for some ports to try rather than prot 80 as for test without fire wall will be dun after new year I think I will switch server modules to the httpd-2.2.3-win32x86-ssl from Apache lounge is it ok to install both Apache at the same time
thank you for all the help Very Happy Bruce


Just ran the command promt and the Apache restarted with no fire walls got the same reply as with the fire walls tried both windows sp2 and Zone Alarm got same reply as the rest
Back to top


Reply to topic   Topic: windows (os)warn View previous topic :: View next topic
Post new topic   Forum Index -> Apache