logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS X


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> Building & Member Downloads View previous topic :: View next topic
Reply to topic   Topic: adding my own module to apache web server
Author
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Wed 21 Nov '07 7:12    Post subject: adding my own module to apache web server Reply with quote

Hi All,

I want to add my own my own module to apache web server.
Is it possible to do so?
If yes, please tell me how.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 7329
Location: Germany, Next to Hamburg

PostPosted: Tue 27 Nov '07 0:01    Post subject: Reply with quote

Did you wrote your module yet?
You can use apxs for building it.
Back to top
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Tue 27 Nov '07 6:08    Post subject: Reply with quote

Hi,

Yah I am ready with the code for the module.
I downloaded the apxs tool from this site.
I went through readme txt file. I executed the following cmd

perl configure.pl "f:\Apache21

But, it gives following error
Can't locate strict.pm in @INC (@INC contains:
I tried by removing the use strict; from the configure.pl but it doesn't server thepurpose. Started giving other errors.
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 611
Location: Milford, MA, USA

PostPosted: Tue 27 Nov '07 15:19    Post subject: Reply with quote

If you have a recent version of Perl, strict.pm should be in your Perl\lib directory. ActiveState Perl v5.8.8 has this module.

Also - you need to use this command per the README file:
Quote:
perl Configure.pl --with-apache2=F:\Apache21 --with-apache-prog=httpd.exe

It is necessary to follow the README file carefully to use apxs on Windows.

-tom-
Back to top
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Tue 27 Nov '07 16:16    Post subject: Reply with quote

Hi,
Thanks for the reply

I installed the same on my sys but now I got new error.

'pl2bat' is not recognized as an internal or external command

This 'pl2bat' is present in the \Perl\bin dir but.......

Thanks in advance..
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 611
Location: Milford, MA, USA

PostPosted: Tue 27 Nov '07 16:29    Post subject: Reply with quote

Are you sure that \Perl\bin is in your PATH environment variable?

This variable should be set by the Perl installation.

Maybe you are still using a command window which was opened before you installed Perl 5.9.8?

-tom-
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 611
Location: Milford, MA, USA

PostPosted: Wed 28 Nov '07 16:27    Post subject: Reply with quote

re: "After success, I got apxs.bat in the F:\Apache21\bin directory."

Yes - you should have apxs.bat and apxs.pl in the \bin directory.

re:"Perl 5.006 required--this is only version 5.00502, stopped at F:\Apache21\lib/File/Copy.pm line 10."

This sounds like you are running apxs with a different version of Perl than you installed apxs with.
Check your PATH environment variable to be sure it points to the correct \Perl\bin directory.
If you changed versions of Perl, you might want to get the apxs download and install it again.

-tom-
Back to top
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Thu 29 Nov '07 6:29    Post subject: Reply with quote

I installed perl 5.8. It started working.
Back to top
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Sun 09 Dec '07 7:13    Post subject: Reply with quote

Hi,

I took the smae thing on w2k3. I got the apxs.bat successfully. But, when I am executing following cmd. I get this err.

C:\apache\bin>apxs.bat -c -i -a -Wc mod_test.c libhttpd.lib libapr-1.lib wsock32.lib
cl /nologo /MD /W3 /O2 /D WIN32 /D _WINDOWS /D NDEBUG -I"C:\apache\include" /c /Fomod_test.lo mod_test.c
'cl' is not recognized as an internal or external command,
operable program or batch file.
apxs:Error: Command failed with rc=65536

does somebody know what is this error. hot to get rid of this.
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 611
Location: Milford, MA, USA

PostPosted: Sun 09 Dec '07 16:37    Post subject: Reply with quote

cl is the Visual C++ compiler.

Maybe Visual C++ is not installed on your win2003 system, or the VSVARS32.BAT file was not executed.

-tom-
Back to top
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Sun 09 Dec '07 16:57    Post subject: Reply with quote

Is it a must to install visual C++ on my system?
Microsoft visual studio 2005 is installed on my system. Does it provide this compiler.
Back to top
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Wed 12 Dec '07 14:56    Post subject: error with apxs.bat Reply with quote

Hi,
I am getting this error while executing the cmd

:>apxs.bat -c -i -a -Wc mod_test.c libhttpd.lib libapr-1.lib wsock32.lib

MSVCRT.lib(cinitexe.obj) : warning LNK4254: section '.CRT' (40000040) merged int
o '.data' (C0000040) with different attributes
if exist mod_test.so.manifest mt.exe /manifest mod_test.so.manifest /out
putresource:mod_test.so;#2
usage: mt.exe [ -f tape ] op [ count ]
apxs:Error: Command failed with rc=65536

Does any body know what is the problem?

Thanks in adv.
Back to top


Reply to topic   Topic: adding my own module to apache web server View previous topic :: View next topic
Post new topic   Forum Index -> Building & Member Downloads