logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache 2.2.2 and PHP5.1.4 (Yes, Again please!)

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
Goblox



Joined: 08 Jun 2006
Posts: 6

PostPosted: Thu 08 Jun '06 0:48    Post subject: Apache 2.2.2 and PHP5.1.4 (Yes, Again please!) Reply with quote

Okay - I've about had it. I've tried various versions of apache and PHP in many combinations and simply can't make them work. But lets start with what we know.

Stephen has in php5apache2.dll for 2.2, instructions included. I'm using someones build: 2.2.2. Is that an issue? I've tried following these instructions letter perfect but as soon as the manifest goes in bin its over. Apache seems to be hopelessly broken.

At this point I'm ready to go somewhere else to get this running asap so if anyone has a PHP/Apache version combination suggestion that would work out of the box - please let me know.

Also, just so we're clear, the PHP5 (Or 4, for that matter) installer has never updated httpd.conf sucessfully - is there any way to fix this?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Thu 08 Jun '06 1:34    Post subject: Reply with quote

Should work. Please search the forum here, there are many posts about this subject.

Steffen
Back to top
Goblox



Joined: 08 Jun 2006
Posts: 6

PostPosted: Thu 08 Jun '06 1:42    Post subject: Reply with quote

I've been searching all day - everywhere =/
When I put httpd.exe.manifest in is when thigns really go wrong.
running from command-line returns "Windows cannot execute the specified program"
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Thu 08 Jun '06 1:46    Post subject: Reply with quote

Did you installed the c++ redistributable, as stated in the Readme of the .zip ?
Back to top
Goblox



Joined: 08 Jun 2006
Posts: 6

PostPosted: Thu 08 Jun '06 1:48    Post subject: Reply with quote

Nearly every attempt has been done after uninstalled all the programs involed and reinstalling them in the various specified order.

Is there another PHP server you'd suggest - and/or when is the next release of PHP5 due out?

edit - and yes - I did install vcredist_x86.exe.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Thu 08 Jun '06 1:51    Post subject: Reply with quote

Maybe you overlooked my question:
Did you installed the c++ redistributable, as stated in the Readme of the .zip ?

Any error messages in the Windows Event viewer ?

An other way is using a PHP 5.2 snapshot, support for Apache 2.2.2 is included: http://snaps.php.net/ . Be aware that is beta/dev.

Steffen
Back to top
Goblox



Joined: 08 Jun 2006
Posts: 6

PostPosted: Thu 08 Jun '06 1:54    Post subject: Reply with quote

Running the C++ Library installer again produces an error - A dll required for this installer to complete could not be run. I assume this is because it has allready been run. Maybe I'll just reformat the thing.

*edit* and concerning "as stated" Yes, I got the installer from that link and ran it - I'm fairly certain if did not give any errors the first time I ran it. Only fools are positive I suppose.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1