logo
Apache Lounge
Webmasters

 

About Forum Index Downloads Search Register Log in RSS X


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Your donations will help to keep this site alive and well, and continuing building binaries. Apache Lounge is not sponsored.
Post new topic   Forum Index -> News & Hangout View previous topic :: View next topic
Reply to topic   Topic: Apache httpd 2.4.58 GA Available :: updated
Author
admin
Site Admin


Joined: 15 Oct 2005
Posts: 677

PostPosted: Thu 19 Oct '23 12:50    Post subject: Apache httpd 2.4.58 GA Available :: updated Reply with quote

Apache httpd 2.4.58 is released as GA.

31 January 2024 Update, see below

ASF and Apachelounge changes : https://www.apachelounge.com/Changelog-2.4.html

Important security vulnerabilities are fixed in 2.4.58, see https://httpd.apache.org/security/vulnerabilities_24.html .

VS17 Win32
The Win32 version is available again, see also discussion https://www.apachelounge.com/viewtopic.php?p=42099
Only build the with the standard Apache modules.
For non-standard modules (like mod_fcgid) use the VS16 Win32 ones at https://www.apachelounge.com/download/VS16/

Documentation: http://httpd.apache.org/docs/2.4/

Build with dependencies:

- openssl 3.1.5
- nghttp2 1.59.0
- jansson 2.14
- curl 8.5.0
- apr 1.7.3
- apr-util 1.6.3
- apr-iconv 1.2.2
- zlib 1.3.1
- brotli 1.1.0
- pcre2 10.42
- libxml2 2.12.4
- lua 5.4.6
- expat 2.5.0

Notes VS17 OpenSSL 3.x.x:

- Only PHP 8.2 and 8.1 (build with 3.x.x) is running as module.
Running with mod_fcgid no issues seen.

For running as module, See also the post from user Otomatic and notes at https://www.apachelounge.com/viewtopic.php?t=8969
and https://www.apachelounge.com/viewtopic.php?t=8938

- With too weak certificates/ciphers Apache does not start, see https://www.apachelounge.com/viewtopic.php?t=8819


Enjoy,

Steffen
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 3045
Location: Hilversum, NL, EU

PostPosted: Wed 31 Jan '24 10:55    Post subject: Reply with quote

Updated the latest dependencies OpenSSL, zlib, nghttp2, curl and libxml2
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 1248
Location: Amsterdam, NL, EU

PostPosted: Wed 31 Jan '24 12:10    Post subject: Reply with quote

Steffen wrote:
Updated the latest dependencies OpenSSL, zlib, nghttp2, curl and libxml2

About an hour before you posted this Curl 8.6.0 was released.
https://calendar.google.com/calendar/embed?src=c9u5d64odop9js55oltfarjk6g%40group.calendar.google.com&ctz=Europe%2FAmsterdam
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 3045
Location: Hilversum, NL, EU

PostPosted: Wed 31 Jan '24 14:58    Post subject: Reply with quote

Too fresh, next build.
Back to top
puertoblack2003



Joined: 31 Jul 2009
Posts: 118
Location: U.S

PostPosted: Wed 31 Jan '24 16:55    Post subject: Reply with quote

thanks guys Cool
Back to top
Pleh



Joined: 01 Feb 2024
Posts: 1
Location: DE

PostPosted: Thu 01 Feb '24 10:25    Post subject: Reply with quote

Thanks for the release.

In addition to the new Curl release a new version for OpenSSL was released too.

Kind regards
Back to top
sindhusagar



Joined: 02 Sep 2021
Posts: 2
Location: India

PostPosted: Mon 05 Feb '24 8:56    Post subject: Regarding Apache httpd older versions Archive Reply with quote

Thanks for the latest release.

I do not find a archive of old releases of apache httpd. Is it maintained on a different server or only latest versions of binaries are available and older versions are discarded when new versions are released.

Base httpd version 2.4.58 prior to January 31 is not available.

Any details on the above is appreciated. Thanks in Advance
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 3045
Location: Hilversum, NL, EU

PostPosted: Mon 05 Feb '24 11:12    Post subject: Reply with quote

Only latest are available.

Which older do you need ?
Back to top
sindhusagar



Joined: 02 Sep 2021
Posts: 2
Location: India

PostPosted: Thu 08 Feb '24 11:25    Post subject: Reply with quote

I need base 2.4.58 version without any patches applied
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 7277
Location: Germany, Next to Hamburg

PostPosted: Fri 16 Feb '24 23:43    Post subject: Reply with quote

sindhusagar wrote:
I need base 2.4.58 version without any patches applied


Apache Lounge compiles without source code modification.
Back to top


Reply to topic   Topic: Apache httpd 2.4.58 GA Available :: updated View previous topic :: View next topic
Post new topic   Forum Index -> News & Hangout